Java "Core Dump Written" Error

Discussion in 'Spigot Help' started by edupaz98, May 5, 2017.

  1. Hello, I've been running a Factions server for a while now and everything has worked fine, until in the last 3 days the server has started to throw this error constantly:

    >#
    # A fatal error has been detected by the Java Runtime Environment:
    #
    # SIGSEGV (0xb) at pc=0x00007ff1a0905232, pid=3604, tid=0x00007fe4320d8700
    #
    # JRE version: Java(TM) SE Runtime Environment (8.0_131-b11) (build 1.8.0_131-b11)
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.131-b11 mixed mode linux-amd64 )
    # Problematic frame:
    # V [libjvm.so+0x637232] PhaseIFG::remove_node(unsigned int)+0x122
    #
    # Core dump written. Default location: /root/tempuspvp/core or core.3604
    # An error report file with more information is saved as:
    # /root/tempuspvp/hs_err_pid3604.log
    #
    # Compiler replay data is saved as:
    # /root/tempuspvp/replay_pid3604.log
    #
    # If you would like to submit a bug report, please visit:
    # http://bugreport.java.com/bugreport/crash.jsp
    #
    Aborted (core dumped)

    I use a OVH machine with 64gb RAM (more than enough I think). Yesterday I had a slightly different error:

    # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again

    I did "ulimit -c unlimited" in terminal and it looks like I kinda fixed that error, but a new one appeared (the first one I showed).

    I'm using Oracle Java 8, and I've already tried re-installing it. But the error persists.

    java version "1.8.0_131"
    Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
    Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

    The server had been working very nice for like 3 months, I did not change any plugin or configuration the days before this error started to happen. If you need more info or the full error logs I can share them.

    Thank you very much for your help.
     
  2. 64GB ram? holy shit, what de **** are you running?
     
  3. Just my Factions server @Erezbiox1 :)

    I like to give the best to my players. Have you got any idea on what's going on with my Java?
     
  4. electronicboy

    IRC Staff

    need the full crash report output
     
  5. No, I don't really understand the shit inside java core,
    Did you try to contact OVH, for a solution?
     
  6. electronicboy

    IRC Staff

    Allocating 50G of memory to a java heap is just stupid and asking for issues...
    Looking at your error, it boils down to either a bug in the JVM (which you'd need to create a bug report for oracle), or bad memory (you'd have to turn the server off and boot into OVHs little recovery OS in order to try test for that)