Solved java.lang.UnsupportedClassVersionError

Discussion in 'Spigot Plugin Development' started by Kyllian, Feb 18, 2020.

  1. Hey,

    I'm currently trying to make a plugin again, though I've been having this issue. I'm currently wondering if it's actually because of my laptop.

    I have this error:
    https://hastebin.com/bafegeyeke.sql

    My maven compiler version is on 1.8, my JDK and JRE are on 1.8, my project level is on 1.8 and my javac compiler is on java 8. I'm out of ideas.
     
  2. SteelPhoenix

    Moderator

    You need to compile your plugin in 1.8 so you've misconfigured your maven, show your pom.
     
  3. Fixed, had to maven clean... lol