1.15.2 Java Runtime version Error

Discussion in 'Spigot Plugin Development' started by sutsui, Mar 23, 2020.

  1. When I try to upload my plugin on my nitrado minecraft server I get this Error:
    • [16:01:50] [Server thread/WARN]: Plugin Tutorial v1.0 does not specify an api-version.
    • at org.bukkit.craftbukkit.v1_15_R1.CraftServer.loadPlugins(CraftServer.java:351) [craftbukkit.jar:git-Spigot-800b93f-8160e29]
    • [16:01:50] [Server thread/ERROR]: Could not load 'plugins/FirstTutorial.jar' in folder 'plugins'
    • org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: SutsuisFirstYtTutorial/Tutorial has been compiled by a more recent version of the Java Runtime (class file version 57.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    • at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:139) ~[craftbukkit.jar:git-Spigot-800b93f-8160e29]
    • at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:334) ~[craftbukkit.jar:git-Spigot-800b93f-8160e29]
    • at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:253) [craftbukkit.jar:git-Spigot-800b93f-8160e29]
    • at java.lang.Thread.run(Thread.java:748) [?:1.8.0_242]
    • at net.minecraft.server.v1_15_R1.DedicatedServer.init(DedicatedServer.java:203) [craftbukkit.jar:git-Spigot-800b93f-8160e29]
    • at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:784) [craftbukkit.jar:git-Spigot-800b93f-8160e29]
    • Caused by: java.lang.UnsupportedClassVersionError: SutsuisFirstYtTutorial/Tutorial has been compiled by a more recent version of the Java Runtime (class file version 57.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    • at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_242]
    • at java.lang.ClassLoader.defineClass(ClassLoader.java:757) ~[?:1.8.0_242]
    • at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.8.0_242]
    • ... 6 more
    • at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:142) ~[craftbukkit.jar:git-Spigot-800b93f-8160e29]
    • at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:92) ~[craftbukkit.jar:git-Spigot-800b93f-8160e29]
    • at java.lang.ClassLoader.loadClass(ClassLoader.java:419) ~[?:1.8.0_242]
    • at java.lang.ClassLoader.loadClass(ClassLoader.java:352) ~[?:1.8.0_242]
    • at java.lang.Class.forName0(Native Method) ~[?:1.8.0_242]
    • at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_242]
    • at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:60) ~[craftbukkit.jar:git-Spigot-800b93f-8160e29]
    • at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[craftbukkit.jar:git-Spigot-800b93f-8160e29]
    Does anybody know how to fix this?
     
  2. md_5

    Administrator Developer

    Pretty obvious if you google it
     
    • Agree Agree x 2
  3. Optic_Fusion1

    Resource Staff

    People don't even know how to check the website for things that have been posted 100+ times
     
    • Agree Agree x 2