Java16 breaks my server version 1.16.5

Discussion in 'Server & Community Management' started by doggstar, Jun 20, 2021.

  1. I installed Java16 and i can run 1.17 just fine

    but when i go back to my 1.16.5 server, it wont accept the new Java

    Code (Text):
    Unsupported Java detected (60.0). Only up to Java 15 is supported.
    I've been looking for an answer on this for about an hour and I cant seem to find many people having this problem, or if they did either the discussion dies off with no resolution or somehow it seems to have get resolved and it's just not clear what they did.

    I'm assuming that I'm doing something wrong, but I just don't know what.

    Thank you for any help
     
  2. I saw the title man, I really tried, I TRIED, but I can't delete the thread.
    *despair*
     
    • Funny Funny x 1
  3. yeah, its funny. i'll be having <insert problem> and im bangin my head, so im like f-it, and try to type up a coherent description. then suddenly i look at it like im someone else, gonna help a noob, and the answer is clear as day and im like OH U FREAKIN DING DONG
     
    • Funny Funny x 1
  4. Happens :D
    I think if you report your own thread with the request to purge it, that they might do it. Just having it in the title probably won't get their attention.
     
  5. i actually did report it first lol. doestn seem to be a priority :)

    or, i thought i did. well, i just did again
     
  6. What, no? Don't delete the thread.

    You found you answer, great. Now it's time to publish the solution in this thread, so you can help others with the same problem.
    Great! Now you have an opportunity to end this trend and publish the answer in a well understandable format so others can benefit from it. There's no reason to delete the thread.
     
    • Winner Winner x 2
    • Agree Agree x 1
  7. So what is the answer?
     
  8. TheJavaHacker

    Supporter

    [​IMG]

    Seriously though -- How did you resolve your issue? What steps did you follow?
     
    • Funny Funny x 1
  9. Fixing My Server: A Play in Two Parts


    3925243.jpg


    update.jpg
     
  10. If there are any plugins for 1.16.5 that don't work yet in java 16 , you can report that to the developers of those plugins.

    java 16 works with spigot 1.16.5 - you can get buildstools.jar and run that on java16 with --rev 1.16.5 and build your own java16 1.16.5 spigot jar and use that.
     
  11. theoretically speaking, if one were to be using a server version that is 300 builds behind current, it probably wouldn't react well to Java16. im just sayin, theoretically and whatnot.
     
  12. TheJavaHacker

    Supporter

    See: THE ALMIGHTY LORD JESUS/STRAHAN!

     
    • Funny Funny x 1
  13. DoYouReallyKnowWhatYouAreDoingISwear?
     
  14. TheJavaHacker

    Supporter

    Code (Text):
    -DIReallyKnowWhatImDoingISwear=false
     
    • Funny Funny x 1
  15. i said theoretically. just asking for a friend. maybe they have other shit going on in their lives okay DONT JUDGE ME I MEAN THEM
     
  16. also maybe they're using a fork that may or may not be appropriate to mention
     
  17. Maybe append this to your jvm startup, see if you get lucky.
    Code (Text):
    --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.security=ALL-UNNAMED
    maybe even
    Code (Text):
    --illegal-access=permit
    teehee
     
  18. I added Java 16 to my PC, which is also my test server, and plugins on my test version of 1.16.5 stopped working. Took me a minute to realize I had to keep using Java 8:
    Code (Text):
    "C:\Program Files\Java\jre1.8.0_291\bin\java.exe"
     
  19. HLEP MEH SERVER DON WORK ON JAVER 16.

    which server?

    I GOT DAT PAPER-1.16.5-434

    would you like to try our "new and improved" build #778

    NAH MANG IM IN A HURRY SEE

    YEA THATS WAT IM LOOKIN FOR! WOOP WOOP


    (srlsy tho, i thought about it. for a half second)
     
    • Funny Funny x 1