Javadoc not working on eclipse

Discussion in 'Spigot Plugin Development' started by Turelis, Jun 4, 2015.

  1. Hey guys,

    I'm having trouble with the javadocs at hte moment working with the latest version of spigot release.

    I'm definately going to the right place I think: https://hub.spigotmc.org/javadocs/spigot/

    but I'm getting an exception in eclipse when trying it tries to create hovertext, only happening with Spigot classes / functions

    java.lang.StringIndexOutOfBoundsException: String index out of range: -10
    at java.lang.String.checkBounds(Unknown Source)
    at java.lang.String.<init>(Unknown Source)
    at org.eclipse.jdt.internal.core.JavaElement.getURLContents(JavaElement.java:786)
    at org.eclipse.jdt.internal.core.BinaryType.getJavadocContents(BinaryType.java:1037)
    at org.eclipse.jdt.internal.core.BinaryMethod.getAttachedJavadoc(BinaryMethod.java:639)
    at org.eclipse.jdt.internal.ui.text.javadoc.JavadocContentAccess2.getHTMLContent(JavadocContentAccess2.java:463)
    at org.eclipse.jdt.internal.ui.text.java.hover.JavadocHover.getHoverInfo(JavadocHover.java:619)
    at org.eclipse.jdt.internal.ui.text.java.hover.JavadocHover.internalGetHoverInfo(JavadocHover.java:565)
    at org.eclipse.jdt.internal.ui.text.java.hover.JavadocHover.getHoverInfo2(JavadocHover.java:557)
    at org.eclipse.jdt.internal.ui.text.java.hover.BestMatchHover.getHoverInfo2(BestMatchHover.java:163)
    at org.eclipse.jdt.internal.ui.text.java.hover.BestMatchHover.getHoverInfo2(BestMatchHover.java:129)
    at org.eclipse.jdt.internal.ui.text.java.hover.JavaEditorTextHoverProxy.getHoverInfo2(JavaEditorTextHoverProxy.java:85)
    at org.eclipse.jface.text.TextViewerHoverManager$4.run(TextViewerHoverManager.java:166)
     
  2. actually doing an updaste on my eclipse to see if it's the version of eclipse being a year old. Will let you guys know.
     
  3. So uhhh... Basically after the update... it's now broken my entire Java development, I can't even start up eclipse, it just fails with loading its modules. Have downloading different versions of eclipse, IDE, Keplar, nothing is working, So I need to figure out what's wrong there =/