Solved JitPack dependency not found

Discussion in 'Spigot Plugin Development' started by MrShawn, Jan 12, 2020.

  1. I'm trying to import my library using JitPack. I've published a release to github: https://github.com/Shawn11564/Cronus/releases/tag/1.0.2
    JitPack shows that release 1.0.2 is there: https://jitpack.io/#Shawn11564/Cronus/1.0.2

    However, when I added the dependency to my pom.xml, it says it cannot find version 1.0.2: https://gyazo.com/c45af47dc9793b93ec46e95a5f83fe87

    I have the jitpack repository added, and it worked for releases 1.0.0 and 1.0.1 of Cronus. I can't figure out why all the sudden it can't find the dependency. I've tried reimporting all maven dependencies, but that doesn't fix anything.

    P.S. I'm using IntelliJ
     
  2. Are you adding a repository?
    Code (Text):
    <repository>
        <id>jitpack.io</id>
        <url>https://jitpack.io</url>
    </repository>
       
     
  3. Yeah, I said that in my post
     
  4. TheJavaHacker

    Supporter

    To be honest, that sounds more like a Jitpack problem, rather than a problem with Spigot or anything in our control. What I would recommend is reaching out to their team to ask for support.
     
  5. Yeah, I didn't think it was a spigot issue, I was just hoping people here would know anything about fixing the issue. I'll contact them.
     
  6. its clearly not their issue, when their servers contain the file in question ( https://jitpack.io/com/github/Shawn11564/Cronus/1.0.2/Cronus-1.0.2.jar )
    i imagine maven is simply not retrieving from the repo. in your error, theres an 'update maven indices' button. press it. see if it helps. if not, restart intellij. check your local repo, see if the file is there. it could have been damaged somehow. delete it and try again.

    /e works for me
    [​IMG]

    /e2 can you post your entire pom.xml?
     
  7. TheJavaHacker

    Supporter

    It's entirely possibly that it was their fault, as they don't immediately cache the requested version, obviously to save storage and such on their end. So when you request it, it may take a few moments before you can start using the software.
     
  8. thats not really their fault though, thats an intended part of their service. besides, op doesnt seem like he waited 3 seconds for it to load and then posted immediately. sounds like he was at it for a while. it simply wasnt updating, which TYPICALLY isnt jitpack's fault (and my testing supports the claim).

    /e phrase correcting
     
  9. Turns out the local file didn't compile correctly. I deleted it and readded it, that fixed it. Thanks for your help!