Spigot JukeLooper 2.2

Looping shuffeled jukebox playlists with redstone and hoppers.

  1. can you please make the use and remove permission not default?

    I gives issues with stacking permissions that we need to deny users the perms first and granting them on a higher rank.
  2. Hello, you should be able to set a minus permission or the permission to false for the default group, then add it back for other groups/users.
    Here is an example with LuckPerms. You can also do this with PermissionsEx.
    Code (Text):
    lp group default permission set jukelooper.use false
    Then add it back to groups.
    Code (Text):
    lp vip default permission set jukelooper.use true
    You can then do the same for the rest of the permissions you want.
  3. I'm giving the user a negative permission on the plugin when they start playing.
    but when a user reach a certain level they get the permission back but the plugin is not responding for them.

    unless we give the perm to the user self.

    Probably this is caused by group inheritance
    all hour groups are inherating the previous group and expand them with new perms.
    This is causing the problem because a deny if more powerfull than a allow on group base.
    the only solution for now is to grant the permission on a player to work around.

    that is why i'm asking you to remove the default setting for use and remove to make it more logical
  4. I could do this, but It may confuse people into thinking the plugin is not working after downloading it if they do not have permission. Have you tried setting the weight of your groups higher than the default?
    Code (Text):
    lp group vip setweight 100
  5. I do not want to have the permissions false by default in the main plugin, as I think it may confuse people. If this is the plugins fault and not a permissions problem I will try find out why it's happening and work on a fix. Until then I have built a version of the plugin for you that has the permissions false by default.

  6. Hey there. I just installed the plugin today and it seems to be working nicely. However, my server has low TPS at times (like down to 12 TPS) and in that case there seems to be quite a long gap between the end of one record and playing the next. Is low TPS causing that? Can it be fixed to work smoother with low TPS? Or is there a built in delay? The times in the config are all default. Thanks.
  7. Hello! Yes, I rewrote the plugin but did not release the update as I have not fully tested it. If you want to try it here it is, JukeLooper.
  8. Awesome! It works like a charm. Thanks!
  9. Great! I will do a full release soon and add better redstone support and support for more containers such as shulker boxes as you said.
  10. This plugin is amazing, but i put disks on loop in certain areas in my server, but when a player teleports to that location, he doesn't hear music until it starts to play again. Is there a fix for it, because i can't find it anywhere. Thanks
  11. If a player comes close to a Jukebox that's already playing there is no way to start playing it from were it is as to sync it with other players, you can only start it from the beginning. I could add an option to start it from the beginning but when it wants to switch it would cut off half way as it's started late for some players. I could also make it so jukeboxes don't play if no one is around, but start only when someone comes by.

    I have been working on a rewrite of the plugin which should improve it a lot, it should be out soon.
  12. Thank you so much for making this! I was about to report an issue, but then I realized I needed to edit the record durations in config.yml since I changed all the sound files and the lengths are different. Once I did that, it's working as expected. I'd love to see it accept any redstone input, not just the wooden button. Thanks again for the awesome plugin.
  13. You seem to have made a mistake with the config that comes with the plugin, as it lists MUSIC_DISC_STRAD twice, replacing what should be ward :p