Killall + Spigot 1.9.4

Discussion in 'Spigot Help' started by dadee971, May 16, 2016.

  1. Hi,
    How can i kill Monsters and animals on Spigot 1.9.4?
    /killall mobs /killall monsters /killallanimals /butcher : thoses commands are not working anymore.
     
  2. Tried updating your plugins?
     
  3. use EssentialsX
     
  4. Does no one actually play Vanilla ever?

    /kill @e[type=!Player]
     
  5. md_5

    Administrator Developer

    Cannot reproduce
     
  6. OK thanks, by the way is there a working version of essentials with 1.9.4?
     
  7. Ok i'll explain till the beginning.
    I have test both version of essentials:
    https://hub.spigotmc.org/jenkins/job/Spigot-Essentials/
    https://ci.drtshock.net/job/EssentialsX/

    When i do /mem it show that i have 198 entities.
    When i do /butcher or / killall mobs, or /killall all, or /killall animals: it says 0 entities killed, and by the way it kills no entities.
    /remove mobs world: nor working too

    It was not the case in 1.9.2, this happend because i have update to 1.9.4.
    And all those commands depends on Essentials, so i guess it is an essentials issue.

    Version :CraftBukkit version git-Spigot-4af49dc-6d133d5 (MC: 1.9.4) (Implementing API version 1.9.4-R0.1-SNAPSHOT)
     
  8. It's maybe bug with Essentials. I think there is no solution for this now. You can downgrade to 1.9.2 or try reinstalling Essentials completely.
     
    #11 bakugan20008, May 16, 2016
    Last edited: May 16, 2016
  9. I'll wait an essentials update then :)
     
    • Agree Agree x 1
  10. Use essentialsX not Regular essentials and update all plugins and that should fix it.
     
  11. As i said 3 time is this post: already tested...
    I even test with a fresh serveur with only essentialsX and it is not working.
     
  12. Can i join you server.
     
  13. What does that even mean?
     
  14. Are you sure you want to know..?
     
  15. Sure
     
  16. Ok this is an issue with healthbar plugin.
    Removing it will cause all the commands to work again.

    Setting:
    show-on-named-mobs: false
    always-shown: false

    Is the solution to keep Healthbar.
     
  17. Just used those commands.
    One 1.9.4 with essentailsX