Kits are completely not working and I cant find a fix.

Discussion in 'Spigot Help' started by kaiegggy, Jun 2, 2017.

  1. I do /kit starter and it comes up with:

    "This kit is improperly defined. Contact an administrator."

    I check the console and it says this:

    "[22:58:02] [Server thread/WARN]: [Essentials] Error parsing kit starter: Invalid kit item: 256"

    I used to have a kit with that but I have updated it and I have then restarted my server. It keeps coming up as 256 but I do not have 256 in the fcking kits section therefore I do not know how to fix this problem.

    My kit config:

    kits:
    starter:
    delay: 86400
    items:
    - 272 1 unbreaking:1
    - 273 1 unbreaking:1
    - 274 1 unbreaking:1
    - 275 1 unbreaking:1
    - 297 20
    - 298 1 protection:2 unbreaking:3
    - 299 1 protection:2 unbreaking:3
    - 300 1 protection:2 unbreaking:3
    - 301 1 protection:2 unbreaking:3
    pvp:
    delay: 259200
    items:
    - 267 1 sharpness:3 fireaspect:1
    - 322:1 1
    - 373:8194 1
    - 373:8257 1
    - 373:8195 1
    - 306 1 protection:2
    - 307 1 protection:2
    - 308 1 protection:2
    - 309 1 protection:2

    or

    https://hastebin.com/kusukicuva.css
     
  2. Try to put the line between '
    Like this:
    kits:
    starter:
    delay: 86400
    items:
    - '272 1 unbreaking:1'
    - '273 1 unbreaking:1'

    I don't have too much idea sorry :D
     
  3. Its ok I fixed it by installing EssentialsX .
     
  4. Oh, Thats great, I'm glad! :)
     
    • Like Like x 1