lag in specific chunks

Discussion in 'Performance Tweaking' started by TheWackyTV, Dec 8, 2017.

  1. Hi there.

    I currently have a world and when I tp to it (or anyone else does) my fps goes down to 3 and I get lag spikes all the time. There is no entities in the chunks, it's an empty world with some houses people can rent with a few chests in it.

    What can cause this?
     
  2. Maybe there are invisible entities generated by a plugin and they load when you join.
     
  3. How can I check this?
     
  4. Maybe pasting your server timings here would tell us if a plugin is lagging or something... (Do [/timings on] and wait 15 minutes then do [/timings paste] and paste the link here).

    Btw this lag can be caused when theres too many Skulls , if you have any skulls in the area try removing them.
     
  5. There and the name of the world is MarcusPvP (which is where the lag is) https://timings.aikar.co/?id=e2934dcd8f1a4458a88a762af3354496
     
    #5 TheWackyTV, Dec 10, 2017
    Last edited: Dec 10, 2017
  6. The problem is the connection handler (Player Join Event) everytime a players joins the server lags.

    You have a lot of intensive plugins , try disabling all the plugins that you dont really need and unninstall plugman (I had really high CPU usage with plugman)
     
  7. I fixed the Player Join Event, it was a plugin that needed to be updated.

    Although this is FPS lag, and it’s there without plugins.
     
  8. Did you try what i told you? (Searching for skulls and removing them all)

    Try doing /killall all and check if the fps lag dissapears.

    If that doesnt work i suggest reducing ticks per tile and entities.

    Oh and search for spawners too , spawners give a lot of fps lag.
     
  9. Yea, there's no skulls. There's only chests, it's cells that people can buy.