Premium Lib's Disguises [Paid]

Discussion in 'Resource Discussion' started by libraryaddict, Nov 30, 2016.

  1. Code (YAML):
    "&cNo PvP while disguised!": "&cLorem ipsum."
    Server restart
    [​IMG]

    (I also found that RetaliationCombat doesn’t work.)
    The description in config.yml is a bit confusing, but I assume that the new RetaliationCombat config option is supposed to let a disguised player PvP if they are attacked first (for the period defined by PvPTimer), like I suggested.

    However, it isn’t working.
    I have two accounts: my main account and my test account. On my test account, I disguised myself. On my main, I attacked my disguised test account, and on my test account, I immediately attacked back, but it still said that PvP is disabled and I can’t attack, and no damage went through.

    Relevant part of config.yml:

    Code (YAML):
    # Should PvP be disabled when disguised?
    DisablePvP
    : true
    # Should PvE be disabled when disguised? (Eg, fighting zombie)
    DisablePvE
    : false

    # How long after disguise wears off, should pvp be allowed again? Requires above to be true
    # Default value 5 seconds
    PvPTimer
    : 5

    # This works with 'DisablePvP' that if attacked by another entity, they have 'PvPTimer' amount of time
    # to attack back. Timer is reset with every successful attack
    RetaliationCombat
    : true
     
  2. libraryaddict

    Patron

    I'll look into it and test it, however this won't be for a while sorry.
     
    • Friendly Friendly x 1
  3. libraryaddict

    Patron

    Fixed, and are you sure you enabled translations in the config?
     
    • Winner Winner x 1
  4. Thanks for fixing it! That didn’t take long after all. :)(y)

    As for the translations… Well, I didn’t know that you had to enable translations in the config. :p After doing so, it works perfectly. :coffee:
     
  5. where do i find the latest build for 1.8?
     
  6. Here is the latest build that works for Minecraft 1.8.8. This build is four years old. I’d imagine it works for 1.8 and 1.8.9 too. If it doesn’t you can find even older builds on this page.

    However, I highly recommend that you update your server (assuming that you own the server you’re playing on; if not, ask the server owner to update) from 1.8 to 1.12.2—or, preferably, 1.15.2. 1.8 is five and a half years old! If you want the new features in both vanilla Minecraft and the plugins that you’re using, the plugins to be stable, and bugs to be fixed, you should update. :coffee:
     
  7. libraryaddict

    Patron

    libraryaddict updated Lib's Disguises with a new update entry:

    Released 9.9.2 for 1.14 and 1.15

    Read the rest of this update entry...
     
  8. libraryaddict

    Patron

    libraryaddict updated Lib's Disguises with a new update entry:

    Released 9.9.3 for 1.14 & 1.15

    Read the rest of this update entry...
     
  9. Having an issue with Libs Disguises 9.9.3 on PaperSPigot 1.15.2 (build #93) where if one player is disguised as an item drop they can't be hit by other players, but can be by mobs etc... (other disguises can be hit by players fine)
     
  10. libraryaddict

    Patron

    Disable the item disguise?
     
  11. Can't really do that when it's a donation perk people already had prior to switching to Libs Disguises because iDisguise doesn't work in 1.14+ - every other disguise you can be hit fine when using, just not the dropped item disguise.
     
  12. Paid but cant download - payment is completed on PayPal and PayPal have confirmed payment has gone through and seller has recieved cleared funds.
     
  13. libraryaddict

    Patron

    Unfortunately there isn't much I can do here.
    I don't want Lib's Disguises to spawn actual fake entities, even though it would improve it in tiny ways like the one you mentioned.
    This issue with the item disguise will not be fixed.
     
  14. libraryaddict

    Patron

    Hey Jack, as I said in discord you will need to wait until your payment clears through paypal.
     
  15. When the plugin allows you to decide if you can be PVP'd or not or whether your disguise should be removed when hit when using disguises this should apply to all disguises. You can shoot them with an arrow fine when they're disguises as a dropped item, but they have no hitbox as far as punching or using a melee weapon is concerned which makes zero sense.

    Prior to updating the server from 1.13.2 we used iDisguise which while not only being a free plugin we did not have to pay for, did not have this issue and it had zero negative effects on the server, use of the plugin or disguises themselves. You could punch people disguised as a dropped item to your hearts content.
     
  16. libraryaddict

    Patron

    And again, item disguise not having a bounding box is most definitely not a bug.

    This is akin to complaining that enderdragon bounding box is too large.
     
  17. libraryaddict

    Patron

    What you are asking for would take weeks of work and would almost double the size of the plugin, just so item disguises can have a bounding box.

    Item disguises are not presented as a usable disguise for survival servers, anyone who thinks objectively about it can realize the potential for exploit. The same for multiple disguises, such as enderdragons and falling blocks.

    Item disguises are included in the plugin because I allow you to disguise as every entity, I don't promise every entity has a fair advantage in PvP.
     
  18. libraryaddict

    Patron

  19. libraryaddict

    Patron

    Public Testing for backwards compatibility builds up to 1.12.
    Premium only, lastest ld builds.

    More information in the discord link on plugin page.

    Sorry about short message, on phone and busy :)