Premium Lib's Disguises [Paid]

Discussion in 'Resource Discussion' started by libraryaddict, Nov 30, 2016.

  1. libraryaddict

    Patron

    You are using the dev builds yes?
     
    • Agree Agree x 1
  2. cowgod

    Supporter

    No, I wasn't clear on whether it was only available in a dev build, but now I know for certain. I will just wait until it's added to an official release (hopefully soon). Thank you.
     
    • Friendly Friendly x 1
  3. onyo it no work. but ill see if an older server version will work for 1.18 clients
     
  4. works with 1 1.17.1 server on 1.18 clients
     
  5. Yo i hope you get the 1.18 update soon!
     
  6. libraryaddict

    Patron

    libraryaddict updated Lib's Disguises with a new update entry:

    Release 10.0.27 with 1.18 support

    Read the rest of this update entry...
     
  7. I use the lib's Disguises premium.It's make me citizens2 have some promble.If player not OP.they can't right click NPC to run some command.
     
  8. libraryaddict

    Patron

    But you didn't purchase the plugin?
     
    • Funny Funny x 1
  9. Hi! I have some problems with free version of plugin on 1.12.2 modded server:
    [09:12:34 ERROR]: [LibsDisguises] Error while trying to register modded entity Deer [09:12:34 WARN]: java.lang.IllegalStateException: Failed to find EntityType id for twilightforest:deer [09:12:34 WARN]: at me.libraryaddict.disguise.utilities.reflection.ReflectionManager.registerEntityType(ReflectionManager.java:1707) [09:12:34 WARN]: at me.libraryaddict.disguise.utilities.modded.ModdedManager.registerModdedEntity(ModdedManager.java:147) [09:12:34 WARN]: at me.libraryaddict.disguise.DisguiseConfig.loadModdedDisguiseTypes(DisguiseConfig.java:826) [09:12:34 WARN]: at me.libraryaddict.disguise.DisguiseConfig.loadConfig(DisguiseConfig.java:551) [09:12:34 WARN]: at me.libraryaddict.disguise.LibsDisguises.onEnable(LibsDisguises.java:229) [09:12:34 WARN]: at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:177) [09:12:34 WARN]: at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:318) [09:12:34 WARN]: at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:399) [09:12:34 WARN]: at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:477) [09:12:34 WARN]: at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:418) [09:12:34 WARN]: at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:315) at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:383) [09:12:34 WARN]: [09:12:34 WARN]: at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:590) [09:12:34 WARN]: at java.lang.Thread.run(Thread.java:748)

    Am I doing something wrong? If so, can you explain this to me?
     
  10. libraryaddict

    Patron

    The error you're posting is a fail error, not the real reason behind the issue. There's another error above that.
     
  11. Is this what you're talking about?

    [10:53:36 INFO]: [LibsDisguises] You are running the free version, commands limited to non-players and operators. (Console, Command Blocks, Admins)
    [10:53:36 ERROR]: [LibsDisguises] MetaIndex not found for HORSE! Index: 17
    [10:53:36 ERROR]: [LibsDisguises] Value: [email protected] (class net.minecraft.item.ItemStack) (class net.minecraft.entity.passive.EntityHorse) & HorseWatcher
    [10:53:37 WARN]: java.lang.NoSuchFieldException: ENTITY_TYPE [10:53:37 WARN]: at java.lang.Class.getField(Class.java:1703) [
    10:53:37 WARN]: at com.mohistmc.bukkit.nms.proxy.ProxyClass.getField(ProxyClass.java:60)
    [10:53:37 WARN]: at me.libraryaddict.disguise.utilities.reflection.ReflectionManager.registerEntityType(ReflectionManager.java:1677)
    [10:53:37 WARN]: at me.libraryaddict.disguise.utilities.modded.ModdedManager.registerModdedEntity(ModdedManager.java:147)
    [10:53:37 WARN]: at me.libraryaddict.disguise.DisguiseConfig.loadModdedDisguiseTypes(DisguiseConfig.java:826)
    [10:53:37 WARN]: at me.libraryaddict.disguise.DisguiseConfig.loadConfig(DisguiseConfig.java:551)
    [10:53:37 WARN]: at me.libraryaddict.disguise.LibsDisguises.onEnable(LibsDisguises.java:229)
    [10:53:37 WARN]: at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:177)
    [10:53:37 WARN]: at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:318)
    [10:53:37 WARN]: at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:399)
    [10:53:37 WARN]: at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:477)
    [10:53:37 WARN]: at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:418)
    [10:53:37 WARN]: at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:383)
    [10:53:37 WARN]: at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:315)
    [10:53:37 WARN]: at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:590)
    [10:53:37 WARN]: at java.lang.Thread.run(Thread.java:748)
    [10:53:37 ERROR]: [LibsDisguises] Error while trying to register modded entity Deer
    [10:53:37 WARN]: java.lang.IllegalStateException: Failed to find EntityType id for twilightforest:deer
    [10:53:37 WARN]: at me.libraryaddict.disguise.utilities.reflection.ReflectionManager.registerEntityType(ReflectionManager.java:1707)
    [10:53:37 WARN]: at me.libraryaddict.disguise.utilities.modded.ModdedManager.registerModdedEntity(ModdedManager.java:147)
    [10:53:37 WARN]: at me.libraryaddict.disguise.DisguiseConfig.loadModdedDisguiseTypes(DisguiseConfig.java:826)
    [10:53:37 WARN]: at me.libraryaddict.disguise.DisguiseConfig.loadConfig(DisguiseConfig.java:551)
    [10:53:37 WARN]: at me.libraryaddict.disguise.LibsDisguises.onEnable(LibsDisguises.java:229)
    [10:53:37 WARN]: at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:177)
    [10:53:37 WARN]: at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:318)
    [10:53:37 WARN]: at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:399) [
    10:53:37 WARN]: at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:477)
    [10:53:37 WARN]: at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:418)
    [10:53:37 WARN]: at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:383)
    [10:53:37 WARN]: at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:315)
    [10:53:37 WARN]: at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:590)
    [10:53:37 WARN]: at java.lang.Thread.run(Thread.java:748)
    [10:53:37 INFO]: [LibsDisguises] Loaded custom disguise libraryaddict
    [10:53:37 INFO]: [LibsDisguises] Loaded 1 custom disguise [10:53:37 INFO]: [LibsDisguises] Config is up to date!
     
  12. libraryaddict

    Patron

    Ah that'll be it, LD doesn't like modded servers