Solved LibsDisguises Not Working [1.11.2]

Discussion in 'Spigot Plugin Help' started by Surprisejedi, May 25, 2017.

  1. I just installed LibsDisguises (Latest Version) with ProtocolLIb (Latest Version). I start my server up and I get an error. None of the commands work either. Here is the Error:

    Code (Text):
    [17:46:04 INFO]: [LibsDisguises] Enabling LibsDisguises v9.3.0-SNAPSHOT
    [17:46:04 WARN]: java.lang.ClassNotFoundException: net.minecraft.server.v1_9_R2.EntityEvoker
    [17:46:04 WARN]:        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91)
    [17:46:04 WARN]:        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86)
    [17:46:04 WARN]:        at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    [17:46:04 WARN]:        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    [17:46:04 WARN]:        at java.lang.Class.forName0(Native Method)
    [17:46:04 WARN]:        at java.lang.Class.forName(Class.java:264)
    [17:46:04 WARN]:        at me.libraryaddict.disguise.utilities.ReflectionManager.getNmsClass(ReflectionManager.java:439)
    [17:46:04 WARN]:        at me.libraryaddict.disguise.LibsDisguises.onEnable(LibsDisguises.java:81)
    [17:46:04 WARN]:        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:292)
    [17:46:04 WARN]:        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340)
    [17:46:04 WARN]:        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405)
    [17:46:04 WARN]:        at org.bukkit.craftbukkit.v1_9_R2.CraftServer.loadPlugin(CraftServer.java:362)
    [17:46:04 WARN]:        at org.bukkit.craftbukkit.v1_9_R2.CraftServer.enablePlugins(CraftServer.java:322)
    [17:46:04 WARN]:        at net.minecraft.server.v1_9_R2.MinecraftServer.t(MinecraftServer.java:416)
    [17:46:04 WARN]:        at net.minecraft.server.v1_9_R2.MinecraftServer.l(MinecraftServer.java:381)
    [17:46:04 WARN]:        at net.minecraft.server.v1_9_R2.MinecraftServer.a(MinecraftServer.java:336)
    [17:46:04 WARN]:        at net.minecraft.server.v1_9_R2.DedicatedServer.init(DedicatedServer.java:268)
    [17:46:04 WARN]:        at net.minecraft.server.v1_9_R2.MinecraftServer.run(MinecraftServer.java:532)
    [17:46:04 WARN]:        at java.lang.Thread.run(Thread.java:745)
    [17:46:04 WARN]: [LibsDisguises] Lib's Disguises failed to startup, outdated server!
    [17:46:04 WARN]: [LibsDisguises] This plugin does not offer backwards support!
     
    I DONT have an Outdated server, I have the latest Spigot 1.11.2. I also am not running ViaVersion (or similar). Can anyone tell me what is wrong?
     
  2. Code (Text):
    net.minecraft.server.v1_9_R2.EntityEvoker
    looks like the "latest version" is referencing a 1.9 version
     
  3. Any recommendations on where to download the 1.11 version?
     
  4. Gaxan

    Supporter

  5. The plugin is using NMS and so breaks with every Minecraft update. You'll need the version to be compatible with 1.11 as you're currently using the 1.9 version.
    I believe what he's asking for is a version of the plugin. The 1.11 version is available here.
     
  6. I'd rather not pay the $5 dollars for it... But when I click on https://ci.md-5.net/job/LibsDisguises/ the file that I download is the one that doesn't work in the first place.
     
  7. Are you using the most recent build (#118). If you are, then I think that the best course of action would be to report it on the developer's issue tracker.
     
  8. Ok will do, the thing is, I remember trying to install LibsDisguises a LONG time ago, and it was the same problem...
     
  9. Umm.... Can't find the Issue Tracker anywhere, can you provide me with a link?
     
  10. Gaxan

    Supporter

    He's using libdisguises 9.3.0 which is current for 1.11.2. He's using Spigot 1.9.
     
  11. Well, this is embarrassing...
    Turns out I was running 1.9.4 after all.
    I can't find the 'Delete Post' anywhere...
     
  12. Gaxan

    Supporter

    What he said and what his console log says, is two different things.
    Read his console log top to bottom.
     
  13. Gaxan

    Supporter

    Just mark it as solved, it happens.
     
  14. Yeah, I forgot to turn back to 1.11.2 after using ViaVersion! I really wish I checked what version I was running before posting this :p