Litebans MySQL (for some reason) not working

Discussion in 'Spigot Help' started by Wolfornator, Jan 9, 2020.

  1. I don't know what i did wrong but it just says "Litebans is not connected to a database"

    My config
    Litebans config.yml
    -
    sql:
    # H2, MySQL, MariaDB, and PostgreSQL are supported database drivers.
    driver: MySQL

    ## MySQL/PostgreSQL settings ##
    # If using H2, the database will be stored in the LiteBans plugin folder,
    # and most of these settings won't apply.

    # Database server address.
    address: cPanelAddress:3306

    # Database name, username and password.
    database: 'Database'
    username: 'Username'
    password: 'Password'
    table_prefix: 'litebans_'
    -

    Website settings.php
    -
    // Database information
    $this->host = 'localhost';
    $this->port = 3306;

    $database = 'Database';

    $username = 'Username';
    $password = 'Password';

    // If you set a table prefix in config.yml, set it here as well
    $this->table_prefix = "litebans_";

    // Supported drivers: mysql, pgsql
    $driver = 'mysql';

    // Server name, shown on the main page and on the header
    $this->name = 'LiteBans';
    -
     
  2. Could you send the console messages from Litebans on startup or reload?
     
  3. [23:59:56] [Server thread/INFO]: [LiteBans] Loading SQL driver: mysql (com.mysql.cj.jdbc.Driver)
    > [23:59:56] [Server thread/INFO]: [LiteBans] Connecting to database...
    > [00:00:27] [Server thread/ERROR]: [LiteBans] litebans-pool - Exception during pool initialization.
    > [00:00:27] [Server thread/ERROR]: [LiteBans] Failed to connect to [jdbc:mysql://ip:3306/database/name_myserver;useSSL=false&serverTimezone=UTC] using mysql driver.
    > [00:00:27] [Server thread/ERROR]: [LiteBans] Error: Failed to initialize pool: Communications link failure
    > [00:00:27] [Server thread/ERROR]: [LiteBans] Cause: connect timed out
     
  4. Try with older version. 2.3.18
     
  5. I tried and it's the same issue