Loaded Class Warning

Discussion in 'Spigot Plugin Help' started by BobbyTowers, Feb 13, 2020.

  1. I'm getting a few of these warnings on start-up. It's only from the legacy plugins. I have the latest version of spigot 1.15.2 It was only after I updated spigot to the newest version it started to happen.

    [18:32:24] [Server thread/WARN]: [Vault] Loaded class com.earth2me.essentials.api.Economy from Essentials v2.17.1.27 which is not a depend, softdepend or loadbefore of this plugin.
     
  2. Did that and the same thing happens.
     
  3. As outdated as anything is, usually you don't have to do anything about warnings. If it's an error, then of course, fix it. However, warnings should be fine. Vault is just saying that it's hooking Essentials Economy
     
  4. Oh whoops I misread that warning. Yeah it isn't anything to be concerned about, shouldn't even be a warning message.