LocalHost Help

Discussion in 'Spigot Help' started by saphiria, May 28, 2015.

  1. saphiria

    Artist

    Could you please help me? Every time I load a plugin on my test server I get this error. (Ive tried 3 different plugins) I am on the latest Spigot build on 1.8.6

    Log
    Code (Text):
    [19:15:19 ERROR]: Could not load 'plugins/KFA.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
        at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:154) ~[Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:291) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.reload(CraftServer.java:744) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at org.bukkit.Bukkit.reload(Bukkit.java:534) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchCommand(CraftServer.java:646) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchServerCommand(CraftServer.java:632) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at net.minecraft.server.v1_8_R3.DedicatedServer.aO(DedicatedServer.java:404) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:368) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:657) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:560) [Spigot.jar:git-Spigot-6a6b839-b0e81a4]
        at java.lang.Thread.run(Thread.java:695) [?:1.6.0_65]
    Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml
        ... 14 more
     
    Cheers,

    Saphiria
     
  2. Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml
    Make a plugin.yml http://wiki.bukkit.org/Plugin_YAML
     
    • Agree Agree x 1
  3. saphiria

    Artist

    Its not my plugin.

    Also i saw this
    Code (Text):
    Warning, your max perm gen size is not set or less than 128mb. It is recommended you restart Java with the following argument: -XX:MaxPermSize=128M
    Please see http://www.spigotmc.org/wiki/changing-permgen-size/ for more details and more in-depth instructions.
     
     
  4. It says that the jar file doesn't include the plugin.yml file.
     
  5. Tell the author to make a plugin.yml.
     
  6. saphiria

    Artist

    So is it a coincidence all three say that?
     
  7. MikeA

    MikeA Retired Moderator
    Retired Benefactor

    Can you list the plugins here?
     
  8. Do you know what the main class is of the plugin then I'll write out the plugin.yml for you ;)
     
    • Friendly Friendly x 1
  9. saphiria

    Artist

    Maintenance, SmileyChat, & KFA. All three i know work. (I installed those three just because i wanted to test the server)
     
  10. Maybe try more ram into your server?
     
    • Funny Funny x 1
  11. saphiria

    Artist

    Okay, though why would that give me that error.
     
  12. Are you trying to run a lot of plugins on a small amount of ram?
     
  13. That's not always true, I get this error most of the time on a 2GB server that only has 5 plugins.
     
  14. Okay, delete your plugins folder.
    And let it regen and re try.
     
  15. If that does not work, put your server to 1.8/1.8.1 spigot
     
  16. The jar file may be corrupted. If other plugins are working that may be the case.
     
  17. It may be Spigot 1.8.6
     
  18. saphiria

    Artist

    How could it be corrupted? I download it off GitHub, then convert the .zip to .jar....
     
    • Funny Funny x 1
  19. Exactly my point. The plugin has to be compiled. A simple file extension name change won't do it.
     
    • Agree Agree x 1
  20. saphiria

    Artist

    *facepalm* Im a noob