Log in lag/packet delay?

Discussion in 'Performance Tweaking' started by FuRiouSOne, Jan 28, 2013.

  1. I have been noticing this problem on my machine the past week or so and it is driving me insane. Hopefully someone can help with this as i have spent a lot of time trying to figure it out with no luck.

    Issue: Randomly when i log in any of my 3 servers (on same machine) i have a 5-20 second delay after i am in game in loading chunks or issuing any commands. This also occurs any time i teleport, the delay happens again after any teleport. I have even opened the RDP to watch the console and the commands i issue to the server after log in are instantly sent such as /lag but takes 5-20 seconds for the server to respond back to me with the info in game chat. After the lag is over i am able to do any commands as normal and get an instant response form the server UNTIL i teleport then it starts its delay again.

    I notice this issue more when i jump between all my servers to admin and/or monitor them in game. If i should log out of my server and log into another server (not mine), then back to my server everything seems normal (chunks load instantly, commands respond back to me instantly and so on).

    Machine specs:
    Deditacted Blade server located in Phoenix Arizona
    E3-1230 v2 3.3GHz 4 core, 8 threads
    16GB DDR3 RAM
    64GB Samsung SSD drive - running my 2 main servers
    500GB HDD drive - running windows, mysql and a non priority server
    Windows Server 2008 R2
    MCMyAdmin professional x3
    1GB port with 3200GB transfer limit (never reach limits)
    Currently using Spigot 417
    Have tested with craftbukkit.jar

    [​IMG]

    What i have done and checked:
    I have checked with other players on the server and they do not have this problem other then one person that brought it up to me which has also stated he noticed it on a feed the beast server he plays on. I have also checked my network configs and all firewall rules and everything is no different then when i first started running my servers over a year ago.

    I also have netlimiter installed just for monitoring purpose and inbound/outbound traffic seems normal. This issue can happen with 10 players (100kbs average) on total or 80+ players (500kbs+) on total (kbs in brackets are total outbound traffic shown in netlimiter).

    I have tried using default minecraft.jar on my home PC thinking it could be on my end but still continues. My home connection is 18MB down, 3MB up and i connect to the server just fine at 120ms (ping) or lower.
     
    #1 FuRiouSOne, Jan 28, 2013
    Last edited: Jan 28, 2013
    • Agree Agree x 3
  2. I have the same issues with my server.

    All of the players have the issue on my server, once it is done loading the chunks only then do /commands or interaction work.

    I have yet to find a solution.
     
    • Like Like x 1
  3. md_5 you delete your post? I tried what you mentioned out but have yet to have the delay happen on my admin account yet so i will keep trying tomorrow and let you know if that worked. I have 2 accounts i use (one to do admin /op duties and one for normal user).
     
  4. md_5

    Administrator Developer

    I deleted it after I realised you said that you tested it on Vanilla.
     
  5. Removed that part, as i did do a test run with minecraft_server.jar but was unable to fully test with players on it along with myself. I didnt notice any delay when i did run it and only myself online but then again there is no /home or /spawn commands in vanilla to really fully test it.

    Your first post that got removed did make since and did log in to all 3 of my live servers with both of my accounts but like i said above i was unable to see the delay even on my admin account with /op and '*' permissions. It does seem to happen in the evenings (central time) for me as thats when im on most.

    I do recall being on both my accounts on the same server making adjustments to plugins one day and did notice both my accounts having this delay issue (teleporting my normal account to my admin account testing out protection areas in game). Could being logged into the same server with 2 accounts under the same IP cause this also?

    Im really concerned if i have a network issue that is only effecting me?
     
    • Agree Agree x 1
  6. Jigsaw

    Supporter

    I have had this issue with my server as well. I don't really see it on teleportation, but I definitely see it when I first log into the server. It doesn't really bother me too much because it is only on initial login and it quickly goes away. I was just assuming it was my home internet being slow, but now it sounds like it is something else.

    Server Specs:
    Intel Xeon 1270 v2
    16 GB DDR3 ECC RAM
    80GB SSD
    500 GB SATA HDD (7200 RPM) (Backup Storage)
    1 Gbps Uplink Port Speed

    PC I am using to connect:
    30 Mbps download / 1 Mbps upload
    Ping to my server is ~75ms
     
  7. PhanaticD

    Patron

    same exact issue on my server, It got a lot better when I switched to a host with a better network but it is still noticeable at times.

    cannot receive chat until chunks load. sending chat is seen in the console and to other players that already loaded the chunks
     
    • Agree Agree x 3
  8. Tried using my normal non admin or OP account after seeing the delay on my admin account and the delay is still there (5-10 seconds). Also on my normal non admin account the delay is there after every single teleport. Once the delay is done everything is normal until i teleport or warp to another location on the map.

    I have even tested with no plugins installed other then essentials just to use teleport, warp and home commands and it will still happen no matter what permissions i have or if i have OP or not.
     
  9. I have my server with http://www.securedservers.com and have been with them for about 5 months now with no problems.

    If its a network issue wouldnt everyone that connects to my servers have the same problem? I have asked several people and they do not have this issue and have had no reports from anyone claiming lag. Everyone has the /lag command and they always state its at 20TPS all the time with rare occasions at 18.3TPS. One other person (one of my moderators) has mentioned he sees this same delay but also mentions he has seen it on other servers hes played on (a feed the beast server).

    My public netword card is an Intel 82580 gigabit card and the link speed is set to 1GBps full duplex. I have checked the download and upload speed of the connection and it can handle just about anything thrown at it. I have uploaded to my dropbox account at 5MB/s (it could be more but dropbox i believe limits its speeds). Even with over 80+ players connected across all 3 servers netlimiter is showing a steady flow of 1-3MB/s upload and 50-200KB/s download which seems normal.
     
  10. Puremin0rez

    Moderator

  11. PhanaticD

    Patron

    you notice the issue if anyone has a bad internet. for instance if your max download speed is 1 kb/s you will probably have to wait like a minute for the chunks to load, and then you will start seeing chat again. chat will still be sent immediately from you, you just wont see it.

    the problem with the last server there was something wrong in the OS and my upload speed on the server was at about a max of 50 kbs and with about 100+ people on this issue became very very obvious. now that I have reinstalled the OS and then after a few days switched to a new host (with gigabit port) the issue is almost non-existant, but when I am at my parents house or at a bad wifi spot at school it becomes more noticeable

    I remember reading somewhere chunk compression was done on the network thread, could that be it?
     
  12. I had the SAME exact issue with a new server...I asked my host to check my port speed and it was only 10mb/s :mad:

    I guess that isn't your issue, but I'd double check.
     
  13. I have the same exact issue with my servers, and I'm most certain it has nothing to do with my plugins or hardware configuration. All my servers are constantly at around 20 TPS with an average of about 100 players online, but as soon as you change worlds/login, there's a noticeable delay.

    That being said, I think it has something to do with bungeecord and not being able to efficiently process all the network traffic between servers . I noticed when I'm running just a single Spigot server without bungee, everything is fine.
     
    #13 nodigit, Jan 30, 2013
    Last edited: Jan 30, 2013
  14. I dont use bungee for my servers so that is not the issue on my end. The past few days i have not been able to get the delay to happen more then 2-3 seconds so unable to report anything new for testing. I am now running spigot 465.
     
  15. Hello guys,

    I want to add that I've had this exact same problem. It only seem to hit in the evenings and for specific players. It's very odd as only a handful out of the 50 players were affected. /lag Takes 5-20 seconds to pop up and when it does it shows 20 TPS. In rare occsasions a relog wouldn't fix it and I had to take more drastic steps to ''fix'' it. At first I thought it was my ISP but that wouldn't make sense because see the next part.

    Like OP I've tried to fix it in all kinds of ways. I swapped 3 pc's and 2 ISPs. I checked my firewall on my server, rebooted tons of times. Disabled plugins like orebfuscator and Citizens. Down and upgraded Spigot. The weirdest thing was that it didn't affect everyone. All in all I came to the following conclusion.

    I'm no expert at java by any means but it looked like some sort of packet buffer issue. As in the server assumed it was sending enough chunk data to the player but at the rate I rendered I estimate it was only 10kb/s. (My home connection is 120mbit down 10mbit up and server is on an 100mbit line)

    Now again I'm sorry if this sounded like bull but this is what it seemed like to me :)
     
    #15 Nikecow, Feb 1, 2013
    Last edited: Jul 15, 2013
    • Agree Agree x 1
  16. Nikecow After running spigot 465 i havnt seen much of the delay as when i made this thread but it is still there, just very rare now. Going to be updating to 473 R1 soon, hopefully it stays rare or completely vanishes.
     
  17. Same here, its much better in the later versions. I'm still pretty scared it will come back again though. Keep us updated please :) and Goodluck!
     
  18. md_5

    Administrator Developer

    .____.
    Now after being fine forever, no server / spigot upgrades, this is happening to me on a server I play on, and I can't log in. Everyone else can see me chat etc, but I can't.

    EDIT: If I use my remote server as a proxy via SSH and connect, I get no lag at all......

    EDIT2: Tested with the network engine rewrite and it worked fine.
     
    #18 md_5, Feb 2, 2013
    Last edited: Feb 2, 2013
    • Funny Funny x 2
    • Like Like x 1
    • Informative Informative x 1

  19. This problem is still occurring on my servers. Is this network engine rewrite in the latest Bungeecord build?
     
  20. md_5

    Administrator Developer

    1) The rewrite is for Spigot
    2) BungeeCord has nothing to do with this