Low performance on my server

Discussion in 'Performance Tweaking' started by AlansS53, Dec 6, 2018 at 3:28 PM.

  1. Hello! Lately I am having low performance on my server, with only a few players online, and I read in a post that the starting arguments of my host server could be the cause of this. I do not have much experience on this and I have not found information of all.
    * My question is whether they could really be the cause or should I look for other problems?

    Start-Up Parameters

    -Xmx4096M
    -Xms4096M
    -Djline.terminal=jline.UnsupportedTerminal
    -XX:+UseConcMarkSweepGC
    -XX:+CMSIncrementalPacing
    -XX:+AggressiveOpts
    -XX:NewRatio=3
    -XX:+UseThreadPriorities
    -XX:CMSInitiatingOccupancyFraction=90
    -XX:+CMSParallelRemarkEnabled
    -XX:MaxGCPauseMillis=50
    -XX:+UseAdaptiveGCBoundary
    -XX:-UseGCOverheadLimit
    -XX:+UseBiasedLocking
    -XX:SurvivorRatio=8
    -XX:TargetSurvivorRatio=90
    -XX:MaxTenuringThreshold=15
    -Xoss4M
    -Xss4M
    -XX:UseSSE=4
    -XX:+UseNUMA
    -XX:+UseCompressedOops
    -XX:+OptimizeStringConcat
    -XX:+UseFastAccessorMethods



    Specifications

    Plugins: 48
    Version: 1.8.8
    Operating system: Linux
    RAM: 4GB DDR4(Always free 1GB)
    Processor: Intel Xeon E5-1650v4 (6c / 12t - 3.6GHz / 4.0GHz)
    Storage: NVMe SSDs in RAID 1
    Connection: 1Gbps
    Spigot Anti-Xray: ON (engine mode 2)
     
  2. If your system only has 4GB of RAM, allocating all 4GB to MC server is definitely not a good idea. The OS also needs some RAM.
     
  3. I do not have a VPS, I run a single server.
     

Share This Page