Low TPS ..

Discussion in 'Performance Tweaking' started by sunghyun, Feb 2, 2019.

  1. MiniDigger

    Supporter

    its in the timings report.....

    @OP, it seems like you have a very bad server, what are your specs?
    EpicFarming seems to be a badly performing plugin so you can try removing that but really, it looks like your server can't keep up.

    also
    > windows server
     
  2. Here! My server plugin list
     

    Attached Files:

  3. Can you check it again?
    https://timings.aikar.co/?id=f2c7aa5061e646eb93d377804cd50d42#timings

    Is there a problem with the Epicfarming plugin?
     
  4. MiniDigger

    Supporter

    as I said, its hard to pinpoint it to a single plugin. what are your specs?
     
  5. maybe upgrade your ram?
     
  6. OP uses 12 gigs already for that server, which is a terrible idea in the first place, 8GB should be the max you allocate or you get gc issues down the lines.
     
  7. My server specs
    E5-2640v3 6Core
    Ram 18G
    SSD 60G
     
    #9 sunghyun, Feb 4, 2019
    Last edited: Feb 4, 2019
  8. Is it better to switch to 8G?
     
  9. It wouldn't do much at all, it would just make it using less ram is all

    You are using an outdated version of PEX, although it is the most updated, the plugin is unmaintained and isn't optimized for 1.12.2 (From what I've seen) as it is recommended by the PEX Author, on the official GitHub page:
    So I would follow his advice and try to switch to LuckPerms and see if that fixes the performance!
     
    #11 GamerDuck123, Feb 4, 2019
    Last edited: Feb 4, 2019
  10. Switch over to LuckPerms and maybe consider a different AntiCheat.
     
  11. Okay. I'll try it.
    Can I recommend Anticheat plugin?
     
  12. Use Spartan if you are on 1.13.2.
     
  13. Which version of 1.12.2 should I use?
     
  14. Based on timings, one garbage collection will take about 120ms, which is triple times more than the one server tick

    Essentials::Command: Essentials:gc
    count(2) total(0.05% 0.239s, 0.08% of tick)
    avg(119.54ms per - 0.04ms/0.00 per tick

    So if your CPU is not hitting 100% (of the single core), it indicates that the garbage collection is causing the problem.

    Try change XX:MaxGCPauseMillis=100 to XX:MaxGCPauseMillis=20 so that it doesn't waste too much time in single gc process. This is just an advisory option, so JVM will not respect it all the time. If it does respect it, then it was wasting the resources for unnecessary gc, but if it somewhat ignores this option, it's probably because it had to gc in order to keep everything running smoothly.

    Nevertheless, it might be simply the problem of not having enough resources to process everything in a given time like @MiniDigger said. In that case, you will need to upgrade your CPU or consider separating servers into multiple servers with bungeecord so that you can utilize all the cores.
     
  15. Mostly yes. the plugin itself has some AI , it will help a lot.
    Trust me.
     
  16. MiniDigger

    Supporter

    Wat. That's BS.
     

Share This Page