Luckperms not working. I've tried a lot to fix it

Discussion in 'Spigot Plugin Help' started by Logos_, Jun 4, 2021.

  1. Server directory upload:
    <redacted>

    Hey,

    Luckperms isn't working with EssentialsX & other plugin's permissions. Despite being part of a group with (world).essentials.balance I can not use /balance or other EssentialsX commands even if I write the permission without the world name. (i.e. essentials.balance)

    These permissions are in the group default.

    I use Paper and have Vault installed.

    Please examine my server directory and the configuration of the plugins I have installed. The jar of Vulcan Anticheat has been removed from this upload as it's a premium plugin.

    Any help is appreciated, I've spent a lot of time trying to get this to work.

    Let me know if you need more information.
     
    #1 Logos_, Jun 4, 2021
    Last edited by a moderator: Jun 4, 2021
  2. Please do not create two topics for the same question :sleep:

    What do you mean it doesn't work?
    Any error in the console when is Luckperms enabled?
     
  3. My bad, that was a mistake.

    When I'm in a group with the perms I mentioned in the first paragraph and try to use their respective commands I'm denied permission to use them. "You don't have access to this command"

    If I use these with verbose mode enabled, their perms show as undefined despite having them in my group.
     
  4. Did you give the permission properly?
     
  5. To my knowledge yes.

    I have include-global-world set to false in my Luckperms config. That means LP will only accept permissions set for certain worlds. To my knowledge you do this by including the world name before the permission in all lower case. (survival.essentials.balance)

    I've tried this and the regular permission without (worldname). to no avail.

    I should mention the group I'm trying this with is my default group.
     
  6. When you set a permission the Luckperms syntax allows you to add in which world it will work, according to what you have said you have already tried

    Could you enable the include-global-world option again and test if it works like this?
    More info
     
  7. Choco

    Moderator

    I've redacted the link in your OP because it...
    • Possibly contains the server .jar file (which is non-distributable)
    • Contains a large collection of plugins which did not permit being distributed
    • Contains world folders which are wholly irrelevant
    • Has other potential security/vulnerability risks for your own safety
    I know I always say "provide more information than you think is necessary" but I think that's a bit much :p If you want to upload information to help with your issue, include your permission-related configuration files (preferably on a paste website or something similar, nobody wants to download random files on the internet).
     
    • Friendly Friendly x 2