Bukkit Magic 7.7.1

Add fully customizable magic wands, items, spells, mobs and more to your server!

  1. Ok so basically it's working but there are a few funny things going on. I reseted my mage data just in case.

    You must specify a class in order to create the quest and the spell is given to you perfectly! it's not inside your inventory, it goes directly to your wand no matter if you're holding it or not, so we could say that works flawlessly.

    However
    , it doesn't matter what your class is, you can still receive the spell...so if you want everyone to get it, sounds fine, but if you actually want to class restrict it then it's not working. If that tiny bug is fixed and multiple classes can be specified it would be awesome :)

    Tried it multiple times and the result was the same, would be cool if someone else tested it too just in case.
     
  2. That should work- that's in your Heroes skills.yml? Try icon-url, I think it may need to be in Heroes' dashed format.

    I think in general a player will automatically be given a class, unless you have "locked: true" in your classes. Do you have that? How do players initially get their class? If you are able to lock them I think it'll work.

    If that doesn't work for you, let me know! I can add a check first for the player having the class already.
     
  3. Dear NathanWolf,

    Thank you very much your answer to my question. Now I read the tutorial.

    Thanks for your attention.
     
  4. Dear NathanWolf,

    I read your tutorial, I understand the section that I put the model in de json, but how can I put this model in some magic item?
    Like this?
    For example:

    -----------------------------------------------------------------------------
    {
    "parent": "item/handheld",
    "textures": {
    "layer0": "items/wood_hoe"
    },
    "overrides": [
    {"predicate": {"damaged": 0, "damage": 0.01666666666667}, "model": "item/custom/lucky"},
    {"predicate": {"damaged": 1, "damage": 0}, "model": "item/wooden_hoe"}
    ]
    }
    -----------------------------------------------------------------------------

    And then I put this in the wands.yml files

    -----------------------------------------------------------------------------
    appearance_wand:
    upgrade: true
    icon: wooden_hoe:0.01666666666667
    upgrade_icon: wooden_hoe:0.01666666666667
    -----------------------------------------------------------------------------

    This is correct?

    If there are any errors, please tell me.

    Thanks for your attention,

    Best regards.
     
  5. I use a Selector action spell which let them choose their class. Can't remember but I think I didn't totally understood what the "locked" parameter was used for and just built my classes based on some defaults (their inheritance comes from the "base" class and their parent is just (caster"). My custom classes are certainly using a locked:false parameter, that means players can get more than 1 class?

    I just tested it with both locked:false/true.

    When it's locked:false, it gives the spell no matter what your class is.

    When it's locked:true, you can still accept and end the quest...but it won't give you the reward. Console throws this message when this is attempted: "Player Atrelyu wants a quest reward of spell wickedwind but does not have class null"

    I think multi-class support should be a thing or else this could be confusing/annoying for players. Also, if players don't meet the requirements (in this case, the requirement is their Class) they shouldn't be able to accept such quest in first place or a warning message explaining the criteria should display. I'm just suggesting how I feel it should behave of course!


    After you create the json model you need to assign it into a tool.
    To do that in a easy way, go here: https://www.accidentalgames.com/media/durabilityModels.php (there's a tiny tutorial youtube link just in case)
    Pick the tool, generate the code, then copy-paste it into a json file that correspond to the tool you just picked.

    In other words, just copy-paste everything, save it with the tool name (by instance iron_shovel.json) inside your resourcepack into the minecraft\models\item folder.

    When you get to this part, instead of using those long numbers, just use 1, 2, 3, 4, 5 and so on.
    If you want to assing the model #1, use just 1.
    Like this: wooden_hoe:1
    If you want to assing the model #150, use just 150.
    Like this: wooden_hoe:150

    I think that solves your question.
     
    • Like Like x 1
  6. Thanks for testing! That all makes sense (except for the message ... not sure why it says "class null")

    So I think we may need a couple of things:

    1. Allow a list of classes in the reward
    2. Add a criteria for having a specific class from a list of classes

    Does that sound right?
     
    • Agree Agree x 1
  7. Dear Atrelyu,

    Yes this part solves my question, but the configuration how distinguish the model if in the json I put this "0.01666666666667" and in the wands.yml file I put this "wooden_hoe:1"

    Thanks for your attention and excuse me the bother,

    Best regards.
     
  8. The value in the json is a ratio, the damage value over the max damage value for that item type. So in the json it will always be something from 0 to 1. In the config files it's just the damage value- so you have to do some math to get them to line up.
     
    • Agree Agree x 1
  9. Dear NathanWolf,

    Thanks for your answer. I prove this.

    Thanks for your attention and excuse me the bother,

    Best regards.
     
    • Friendly Friendly x 1
  10. Sounds perfect to me :) basically multi class support and their respective requirements so players who doesn't meet the criteria won't be able to take the quest in first place.

    Always glad to help! tell me if there's anything else I can do.

    While writting this I would also like to report something a bit weird regarding Magic+Citizens and the "traits".

    Sometimes, on server start (I never use "reload", just in case), Citizens NPC's are missing either their hats or their invisibility...other times it's just working perfectly. No errors on console so I'm not totally sure what this could be. If by any chance this have to do with a crappy internet connection then that would be an error by my side but I don't see why that would affect such behaviour so I guess it might be something else :unsure:
     
  11. Ok please test the new version: http://jenkins.elmakers.com/view/Add-Ons/job/MagicQuests/97/
    "Class" can now be a list (comma separated), and I added a mage class requirement.

    As for the Citizens issue... I've noticed that too, occasionally, but I do not know what causes it :(
     
  12. NathanWolf updated Magic with a new update entry:

    1.14 Support

    Read the rest of this update entry...
     
  13. Works perfectly now :) the requirements, multi-class support and literally evertyhing else are just perfect. I tested it with the builds pre 1.14, will try later with the new one and post something if there's anything wrong but I doubt so.
    Sorry for the delay! I got a local server to test things and stuff so if you kind of need anything like this just tell me. I won't promise that I will do it right away of course lol, but the help is there if needed.

    As for the citizens issue, how unfortunate :( I just have noticed that reloading magic won't work, only a server stop/start and it might be needed a few times. If I can help with this just tell me.
     
    • Friendly Friendly x 1
  14. Dear Sir or Madam,

    Is posible make hats with the magic items? If this is possible, can you tell me how to do it?

    Thanks for your attention and excuse me the bother,

    Best regards.
     
    • Friendly Friendly x 1
  15. Yeah, but instead of items you use custom wands with the sole purpose of staying on your head and not casting any other spells.
    Look into your wands.defaults.yml and search for the "goggles" and "divinghelmet" examples :)
     
    • Agree Agree x 1
  16. Dear Atrelyu

    Thanks you very much your answer

    And excuse me the bother,

    Best regards.
     
    • Friendly Friendly x 1
  17. Dear Atrelyu,

    I don't have the file "wands.defaults.yml", can you tell me the example please?

    Thanks for your attention and excuse me the bother,

    Best regards.
     
  18. The plugin uses those files literally every time it launches; make sure to double check.
    It should be in plugins>magic>defaults>wands.defaults.yml

    I'm still leaving the examples here but you really should double check that.

    divinghelmet:
    mode: cast
    active_spell: wear
    icon: stained_glass:3
    indestructible: true
    locked: true
    keep: true
    quiet: 2
    mana_regeneration_boost: -0.1
    potion_effects: water_breathing
    passive: true
    enchantments:
    oxygen: 3
    water_worker: 1
    depth_strider: 3
    spells:
    - wear

    goggles:
    mode: cast
    icon: wood_hoe:16
    migrate_icon: monster_eggs:1
    indestructible: true
    locked: true
    keep: true
    passive: true
    mana_regeneration_boost: -0.1
    potion_effects: night_vision:3
    glow: true
    active_spell: wear
    quiet: 2
    spells:
    - wear
     
    • Friendly Friendly x 1
  19. @NathanWolf Hey there! Is there any way to make an NPC automatically target single/multiple players at a specific range then cast a spell on them?

    I'm 100% sure that you could use "/castp" on command blocks along with some arguments...like: /castp missile @a[r=5]
    I remember that some extra arguments were used to target the player's appropiate location.

    Is this posible with Citizens NPCs? If so, how?
    If NPCs can't do this but command blocks can, could you please tell me how?
    I'm also open for other alternatives like Skript...but since Magic have so many features maybe It's already there and I'm missing it, plus it would be way much easier.

    Thanks in advance!

    EDIT: Tried "/castp @p[distance=..20] missile" using a command block. It works...but it doesn't target the player, just shoots the spell at the air and the command block must be activated every time you want it to shoot.
     
    #4200 Atrelyu, May 4, 2019
    Last edited: May 4, 2019

Share This Page