Spigot Magic 7.9.5

Add fully customizable magic wands, items, spells, mobs and more to your server!

  1. How can I disable magic from a world? wolrdguard tags do not work :( or how can I de-activate all the spells of a world ?? thanks
     
  2. Hi, was unsure where to post this, but this is for the MagicQuest Module that connects to the Quests plugin...
    When I was using the module to select a custom objective, I got all the way to entering the value, but when I typed "2" to be Done, the value message just keeps repeating itself...
    The files doesn't save/cancel, and I don't know what the format is in the quest file, otherwise I would have just typed it out in the file...
    Wondering if I could get some help, either I'm putting the wrong thing in where I have been putting Fireball or if I could get an idea of how to just type out the custom objective in the Quests file..Thank You!
    P.S. This happens for all the custom objectives in the MagicQuests Module not just the Spell one... Capture.PNG
     
    • Agree Agree x 1
  3. It seems that on 1.14.4 players can use enchanting tables with wands, it doesnt do anything
     
  4. Whatever that plugin is doing I don't think I can do anything to fix it.

    It looks like the issue is the inventory got too big and this is no longer allowed, so it doesn't display at all.

    Unfortunately there's no real easy fix for this, I need to make the spell shop paged which will take some work. For now I'll find out what the limit is and just cut if off if it gets too big- this will be in the next dev build.

    The shop has 16 colors but all 64k colors are supported via configs or commands.

    In items.yml, add this:

    Code (Text):
    rotten_flesh:
      worth: 1
    And change it to whatever you want

    1.14 has been supported since day 2 of release. I neglected to update the project page, this is fixed now.

    Is this maybe related to the inventory getting too big? Normal players shouldn't run into that problem, but if they have like 100 spells available it might fail.

    Worldguard is the only way. What flags have you tried and how are they not working?

    Are there any errors in the server logs?
     
  5. No errors seen when trying to enter "2" as a response, just the repeat and no errors seen when the module loads in with Quests...
     

    Attached Files:

  6. I just set up Quests myself and tried it out, and I'm seeing the same behavior.

    I wonder if @PikaMug could help? Sorry for the ping... is there something that maybe changed recently in custom modules? The problem is when I select the "Done" option while adding my custom objective, it does not finish it just repeats that same menu.
     
  7. We resorted to giving me the spells i want through commands and retract the spellpoints manually from my character for the time being. Thank you for the reply, Nathan. Stay awesome!

    Cheers,

    TheCaptain43
     
  8. @NathanWolf I've confirmed the behavior, but it seems to only be happening with MagicQuests. Just tested with the DungeonsXL module and the custom objectives work fine, even if I have both installed at once. The code within Quests was updated back in April, so it's possible something broke - I'll have to investigate further.

    @sameethan1 If you could create an issue including your Quests, MagicQuests, and Magic versions, it'd help get this fixed sooner: https://github.com/PikaMug/Quests/issues/new/choose
     
    • Like Like x 1
    • Friendly Friendly x 1
  9. Thanks~ One more thing am i able to disable the landscape regenerating from spell damage
     
  10. Not super easily as it's on a spell-by-spell basis, but I suppose if you're feeling very brave you could put this in spells.yml

    Code (Text):
    override:
      parameters:
        undo: 0
    I think that'd effectively make all spells permanent. Wouldn't recommend.

    Thank you for looking at it! I'll open an issue.

    EDIT: Actually I won't since @sameethan1 already did, but I'll be following it. Please let me know if I can help!
     
  11. @NathanWolf I'm about to release Quests 3.7.7 which will resolve the issue. No changes to your module are necessary.

    However, would you be able to update the link on the MagicQuests Jenkins? It currently points to the old, abandoned page for Quests.
     
    • Friendly Friendly x 1
  12. Hello Nathan, I have a problem with the plugin. How do i get the engineer, architect and Conduit wand with a command. i bought all spells and still dont get it.
     
  13. Use: /mgive playername wand:wandname

    Example: /mgive Atrelyu wand:engineer
     
    • Friendly Friendly x 1
  14. Thank you, and done!

    https://github.com/elBukkit/MagicPlugin/wiki/Progression#engineering-magic

    To cheat, do "/cast engineershop" then "/cast architectshop" then "/cast conduitshop".
     
  15. OriginalPhizzle

    OriginalPhizzle Previously BewnyKLI82

    Hello, is it possible to turn off the broom, the use of a magic stick, etc., in a certain world? and where to do it?
     
  16. Hello @NathanWolf

    Is there a downloadable version of the texurepack in 1.12? If there is, can you send it to me?
     
  17. PawPawDude

    Supporter

    A bit odd that you haven't mentioned Citizens NPCs in the Overview at all, not even a word. What else are we going to miss about this plugin? It looks great, but wouldn't you want to list the key features more thoroughly? :unsure:
     
  18. how can I disable players from crafting Emerald swords? They're stronger than diamond, unbreakable and super easy to make.
    Edit: went into the crafting.yml and added emeraldsword and emerald_sword set them do enabled: false and then reloaded the server and now the whole plugin get's disabled bc it says there's an error loading the config.
     
    #4278 MrRayhonda, Aug 9, 2019
    Last edited: Aug 10, 2019
  19. Latest version on 1.14.4 and not able to craft a broomstick for some reason :(
     
  20. So I got a question about the custom mobs, I have been creating them for my dungeons, however I noticed the EnderDragon doesn't move when spawned with the /mmob spawn, wondering if I am doing something wrong, or if it's possible for you to get him to act normally, but still connect to cast spells? I have been slowly working towards a custom End world, and rework the battle with the dragon, but won't really be able to do that if he just floats in one spot...Hope you can help out! Amazing plugin and connects well with a lot of mechanics!