1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Mass disconnects for "generic reason"

Discussion in 'Bugs & Feature Requests' started by LiipeBR, Mar 14, 2014.

  1. Hi..
    My server its getting this bug, i don't know why :(
    Pm: I have a anti-ddos..
    [​IMG]
    And sometimes i get this error:
    2014-03-11 14:04:20 [WARNING] Failed to handle packet for loio/23.228.67.62: java.lang.IndexOutOfBoundsException: Index: 45, Size: 45
    java.lang.IndexOutOfBoundsException: Index: 45, Size: 45
    at java.util.ArrayList.rangeCheck(Unknown Source)
    at java.util.ArrayList.get(Unknown Source)
    at net.minecraft.server.v1_5_R3.Container.getSlot(Container.java:105)
    at net.minecraft.server.v1_5_R3.PlayerConnection.a(PlayerConnection.java:1209)
    at net.minecraft.server.v1_5_R3.Packet102WindowClick.handle(SourceFile:31)
    at org.spigotmc.netty.NettyNetworkManager.b(NettyNetworkManager.java:215)
    at net.minecraft.server.v1_5_R3.PlayerConnection.d(PlayerConnection.java:115)
    at net.minecraft.server.v1_5_R3.ServerConnection.b(SourceFile:35)
    at org.spigotmc.MultiplexingServerConnection.b(MultiplexingServerConnection.java:72)
    at net.minecraft.server.v1_5_R3.MinecraftServer.r(MinecraftServer.java:583)
    at net.minecraft.server.v1_5_R3.DedicatedServer.r(DedicatedServer.java:227)
    at net.minecraft.server.v1_5_R3.MinecraftServer.q(MinecraftServer.java:472)
    at net.minecraft.server.v1_5_R3.MinecraftServer.run(MinecraftServer.java:404)
    at net.minecraft.server.v1_5_R3.ThreadServerApplication.run(SourceFile:573)

    Help !!
    IP: jogar.tintapvp.com

    Thank u
     
  2. Please somebody can help me ? '-'
     
  3. Dmck2b

    Services Staff

    You're using a build from 9 months ago that showed there were already networking concerns, what do you expect really? Upgrade to something that isn't two majour version changes old..
     
    • Agree Agree x 1
    • Winner Winner x 1
  4. Affixes

    Supporter

    @Dmck2b Upgrading? Aint nobody got time for that.
     
    • Optimistic Optimistic x 1
  5. So give me an build for 1.5.2 servers !!
    OBS: My other server with 1.6.4 version have the same problem.

    Thanks you !
     
  6. Dmck2b

    Services Staff

    Neither 1.5.*/1.6.* receive support from Mojang, Bukkit or Spigot. If you want fixes, upgrade to 1.7 and attempt to replicate.
     
    • Agree Agree x 1
  7. But i cant upgrade '--'
    This error appear when i put anti-ddos!
    Please try to helpme '
    OBS: I'm using reverse proxy
     
  8. I am not sure what is going on.