Maven issue

Discussion in 'Spigot Plugin Help' started by Kozs, Sep 8, 2018.

  1. Is anyone familiar what I may be doing wrong with these two dependencies?

    Code (Text):

    <!--Spigot API-->
    <dependency>
        <groupId>org.spigotmc</groupId>
        <artifactId>spigot-api</artifactId>
        <version>1.12-R0.1-SNAPSHOT</version>
        <scope>provided</scope>
    </dependency>

    <!--Bukkit API-->
    <dependency>
        <groupId>org.bukkit</groupId>
        <artifactId>bukkit</artifactId>
        <version>1.12-R0.1-SNAPSHOT</version>
        <scope>provided</scope>
    </dependency>
    Tired.. need a second pair of eyes! This is a basic project and I have this
    whole file here:
    https://pastebin.com/wx4LUTZT
     
  2. Did you add spigot repository to this pom file? Dependency without repositories cannot be searched anywhere.
     
    • Like Like x 1
  3. There is no reason to use the 1.12 API, use 1.12.2. You're missing at least half a year of API additions.
     
  4. Added it, forgot about it thanks.

    Useless post
     
    • Like Like x 1
    • Optimistic Optimistic x 1