Maven Project

Discussion in 'Spigot Plugin Help' started by Ventrix, Mar 6, 2018.

  1. Hi Guys,
    I just wanted to ask if anyone can give me a maven pom.xml,
    the spigot version should be 1.8.8
    if you need more information tell me:>)

    if I try it myself, it comes:
    Failed to execute goal on project Lalal: Could not resolve dependencies for project me.ventrix:Lalal:jar:1.0-SNAPSHOT: Could not find artifact org.spigotmc:spigot-api:jar:1.8.8-R0.1-SNAPSHOT -> [Help 1]

    To see the full stack trace of the errors, re-run Maven with the -e switch.
    Re-run Maven using the -X switch to enable full debug logging.


    mfg: Ventrix
     
    #1 Ventrix, Mar 6, 2018
    Last edited: Mar 6, 2018
  2. Doesn't this stuff show up when you use buildtools to create 1.8.8 ?
     
  3. Yes, that's why I ask so I do not know exactly what it lends but I guess in my pom.xml and I'm looking for pros who know about it
     
  4. So I've just tested my plugin and it comes a mistake,

    here is the error
    Code (Text):
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:154) ~[spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52] at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52] at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52] at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52] at java.lang.Thread.run(Thread.java:745) [?:1.8.0_112] Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml
    and here is my main and plugin.yml

    plugin.yml:
    Code (Text):
    name: test
    author: sam
    main: me.ventrix.main.main
    version: 1.0
    and here my main
    Code (Text):
    /*
     * To change this license header, choose License Headers in Project Properties.
     * To change this template file, choose Tools | Templates
     * and open the template in the editor.
     */
    package me.ventrix.main;

    import org.bukkit.plugin.java.JavaPlugin;

    /**
     *
     * @author MaxReturns
     */
    public class main extends JavaPlugin {
       
        public void onEnabele() {
            System.out.println("Test");
        }
       
        public void onDisable() {
            System.out.println("Test");
           
        }
       
    }
     
     
  5. gist your pom.xml.

    It looks like you should update <repositories> section and <resources> section to resolve your issues.
     
  6. how do you mean that?
     
  7. No it does not work

    error
    Code (Text):
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:154) ~[spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52] at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52] at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52] at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot-1.8.8.jar:git-Spigot-21fe707-e1ebe52] at java.lang.Thread.run(Thread.java:745) [?:1.8.0_112] Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml
     
  8. Post a gist link with your current Pom.xml. Then he can fix it for you.
     

Share This Page