Solved Mcmmo not working

Discussion in 'Spigot Plugin Help' started by D3TheThird, Feb 19, 2020.

Thread Status:
Not open for further replies.
  1. I'm running a spigot 1.8.8 server and I have mcmmo installed, currently version 1.5.04. But it does not seem to be working. Any ideas why? I tried other version including the latest one and no success. Please help. Thank you.
     
  2. When you say its not working, what do you mean? 1.5.04-snapshot is the correct version for 1.8.8 but you will also need to setup permissions if you haven't already.

    If the plugin is red in /pl, look for a error when you server starts and send the *full error*
     
  3. Not working like not even commands work. Permissions are already setup, I have ranks already setup. Plugin is in fact red and the error I get is this:

    [18:31:10] [Server thread/INFO]: [mcMMO] Enabling mcMMO v1.5.04-b${BUILD_NUMBER}
    [18:31:10] [Server thread/ERROR]: [mcMMO] There was an error while enabling mcMMO!
     
  4. Like I said we need the full error, there will be a bigger error somewhere in the startup. If for some reason you're unable to find it post your full startup log (It'll be inside the logs/ folder) to a paste site. Also, where did you get this build of mcmmo?
     
  5. I'm at work right now but later today I'll post the full log. The version came with a prebuilt server that I bought. If I buy the latest version will that work with 1.8.8?
     
  6. 1.8 is officially not supported. classic mcmmo 1.6 and mcmmo overhaul 2.1 both work on spigot 1.15.2
    try upgrading.
     
    • Optimistic Optimistic x 1
  7. Overhaul does not support 1.8.8, neither does classic. If you buy classic here, there is a download link to the latest version that works on 1.8.8 in its description.
     
  8. Okay I'll give it a try once I get home, I'll keep you updated.
     
  9. I just saw that the version you're talking about is 1.5.04. That's the one I have.
     
  10. There was an issue for a while where the download link was pointing to the wrong 1.8 jar, they might have gotten it during that time. Or you've made a mistake in configuring it which is stopping it from starting, we'd need the startup log to figure that out though.
     
  11. Looks like all the configs are messed up, delete everything inside the mcmmo/ folder
     
  12. Must be the jar then, try a clean one when you get home
     
  13. Can explain what u mean by a clean one? Which one should I buy?
     
    • Useful Useful x 1
  14. If it's not your configs it couldn't really be anything else, you're more than welcome to join the mcmmo discord and ask there though.
     
    • Like Like x 1
  15. I'll try once I get home (about 2 hours) I'll buy it and I'll go from there. I'll keep you updated. Thanks
     
  16. All sorted. MCMMO finally working! Thank you everyone for the help!
     
    • Winner Winner x 1
Thread Status:
Not open for further replies.