Spigot MeteoritesPro v1.5.3

The Ultimate Meteorites Plugin

  1. OliPulse updated MeteoritesPro with a new update entry:

    Minor Tweaks

    Read the rest of this update entry...
     
  2. OliPulse updated MeteoritesPro with a new update entry:

    v1.3

    Read the rest of this update entry...
     
  3. Can a feature where i could turn protection for all world guard regions be added, cause we are plannin on manually adding protection to bases with worldguard.
     
    • Like Like x 2
  4. PawPawDude

    Supporter

    MeteoritesPro looks really great, dev. Thanks for filling the vacated niche. I especially appreciate your stated approach to customizability. (I haven't installed yet, but will soon)

    One question:
    Similar to as @SlimeDog suggested, being able initiate and control from console is critical. Player-only launching of meteorites is limited, whereas console control allows scripting and other applications. Or, have you added console functionality already?

    I didn't see it in the Overview description, but ideally I'd think the following example would be perfect (pseudo-code):
    Code (Text):
    /meteor --target <world> <x> <y> <z> --originatingfrom <x> <y> <z> --diameter <n> --composition block,block,block,block --explosionstrength <some scope value> --commandonlaunch <command string> --commandonexplosion <command string>
    Note that the target location could be in the air, as many incoming meteors do. Executable commands before and after would allow for maximum adaptability to the game scenario scheme.

    Thanks again. Will give it a spin.
     
    • Agree Agree x 1
    • Winner Winner x 1
  5. OliPulse updated MeteoritesPro with a new update entry:

    v1.4

    Read the rest of this update entry...
     
  6. Code (Text):
    09.11 16:24:11 [Server] ERROR Could not load 'plugins/MeteoritesPro.jar' in folder 'plugins'
    09.11 16:24:11 [Server] INFO org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/olipulse/meteoritespro/MeteoritesPro has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    09.11 16:24:11 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:138) ~[patched_1.14.4.jar:git-Paper-225]
    09.11 16:24:11 [Server] INFO at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:337) ~[patched_1.14.4.jar:git-Paper-225]
    09.11 16:24:11 [Server] INFO at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:257) ~[patched_1.14.4.jar:git-Paper-225]
    09.11 16:24:11 [Server] INFO at org.bukkit.craftbukkit.v1_14_R1.CraftServer.loadPlugins(CraftServer.java:355) ~[patched_1.14.4.jar:git-Paper-225]
    09.11 16:24:11 [Server] INFO at net.minecraft.server.v1_14_R1.DedicatedServer.init(DedicatedServer.java:226) ~[patched_1.14.4.jar:git-Paper-225]
    09.11 16:24:11 [Server] INFO at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:876) ~[patched_1.14.4.jar:git-Paper-225]
    09.11 16:24:11 [Server] INFO at java.lang.Thread.run(Thread.java:748) [?:1.8.0_144]
    09.11 16:24:11 [Server] INFO Caused by: java.lang.UnsupportedClassVersionError: me/olipulse/meteoritespro/MeteoritesPro has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    09.11 16:24:11 [Server] INFO at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_144]
    09.11 16:24:11 [Server] INFO at java.lang.ClassLoader.defineClass(ClassLoader.java:763) ~[?:1.8.0_144]
    09.11 16:24:11 [Server] INFO at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.8.0_144]
    09.11 16:24:11 [Server] INFO at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:135) ~[patched_1.14.4.jar:git-Paper-225]
    09.11 16:24:11 [Server] INFO at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:85) ~[patched_1.14.4.jar:git-Paper-225]
    09.11 16:24:11 [Server] INFO at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_144]
    09.11 16:24:11 [Server] INFO at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_144]
    09.11 16:24:11 [Server] INFO at java.lang.Class.forName0(Native Method) ~[?:1.8.0_144]
    09.11 16:24:11 [Server] INFO at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_144]
    09.11 16:24:11 [Server] INFO at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:63) ~[patched_1.14.4.jar:git-Paper-225]
    09.11 16:24:11 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:134) ~[patched_1
     
    • Like Like x 1
  7. It looks like my tweak didn't solve this issue yet. Trying to fix this ASAP!
     
  8. OliPulse updated MeteoritesPro with a new update entry:

    v1.4

    Read the rest of this update entry...
     
  9. @Gustavo_Player
    The issue is officially fixed now. Had to re-upload v1.4 for some reason!
     
  10. Hi i use last update and your plugin giving me error:
    Code (Text):
    [21:54:54] [Server thread/ERROR]: Could not load 'plugins\MeteoritesPro.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/olipulse/meteoritespro/MeteoritesPro has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:139) ~[spigot.jar:git-Spigot-9de398a-9c887d4]
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:334) ~[spigot.jar:git-Spigot-9de398a-9c887d4]
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:253) [spigot.jar:git-Spigot-9de398a-9c887d4]
            at org.bukkit.craftbukkit.v1_14_R1.CraftServer.loadPlugins(CraftServer.java:350) [spigot.jar:git-Spigot-9de398a-9c887d4]
            at net.minecraft.server.v1_14_R1.DedicatedServer.init(DedicatedServer.java:194) [spigot.jar:git-Spigot-9de398a-9c887d4]
            at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:776) [spigot.jar:git-Spigot-9de398a-9c887d4]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_221]
    Caused by: java.lang.UnsupportedClassVersionError: me/olipulse/meteoritespro/MeteoritesPro has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
            at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_221]
            at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.8.0_221]
            at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.8.0_221]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:131) ~[spigot.jar:git-Spigot-9de398a-9c887d4]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:81) ~[spigot.jar:git-Spigot-9de398a-9c887d4]
            at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_221]
            at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_221]
            at java.lang.Class.forName0(Native Method) ~[?:1.8.0_221]
            at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_221]
            at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:59) ~[spigot.jar:git-Spigot-9de398a-9c887d4]
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot.jar:git-Spigot-9de398a-9c887d4]
            ... 6 more
    [21:54:54] [Server thread/INFO]: [Essentials] Loading Essentials v2.16.1.0
     
  11. Please re-download the latest version and this should be fixed. Can you confirm this to me? Thanks in advance!
     
  12. Yes new version is ok perfect plugin nice work man
     
    • Friendly Friendly x 1
  13. When the meteorite is cleared, the item in the barrel drop, you can change it?
     
    • Like Like x 1
  14. I noticed this too, I'll take a look at options to not make the treasure items drop when the meteorite gets cleared. Thanks for reporting :)
     
  15. Please make so works with Towny as well?
     
    • Like Like x 1
  16. OliPulse updated MeteoritesPro with a new update entry:

    Tweaks

    Read the rest of this update entry...
     
  17. It'd be very nice if you could add an API, maybe with an event we can listen to on meteorite spawn, & crash that let's us know meteorite type and location, movement speed & direction, and allows us to cancel the spawn?

    Thanks for considering it, it'll probably save you a lot of different requests for compatibility to x plugin ;)
     
    • Winner Winner x 1
  18. That's a great suggestion, thanks! :D
     
    • Like Like x 2
  19. OliPulse updated MeteoritesPro with a new update entry:

    Tweak

    Read the rest of this update entry...
     
  20. Another "bug": When the chunk unload, the Meteorite Guardian dissapear.
     
    • Like Like x 1