Spigot MidiPlayer 0.2.0

A plugin that allows you to play custom music on your server.

  1. I never tried such large MIDI files. The loading is done in the server main thread so ye it can freeze the server. I never thought of using this to play 50M MIDI files :p. For such large files it should be redesigned (parse files on the fly instead of loading all the notes to memory).

    Unfortunately not, but that would be a simpl fix.

    Currently it is not possible, but I'll see what can be done. This might be problematic because players that use the resource pack also have the default sounds. This would require some sort of user sign in for different sound configs.

    Those are interesting features but as you can see the plugin is at version 0.2. Basically it was only a proof of concept :p

    First thing first, the idea is great :D But I have no idea how to connect to an external MIDI device. I can create an API in my plugin that would allow you to request different notes to be played. But the MIDI instrument integration would require an extra plugin.

    I added issues for your suggestions (https://github.com/SBPrime/MidiPlayer/issues) well see how this goes.
     
    • Like Like x 1
  2. Hello! I am so glad you updated this. I use the 0.10 release all the time with my 1.7.10 server.

    Testing it with my 1.11 server, Minecraft says the GM Resource Pack is "Incompatible (Made for an older version of Minecraft)"

    So I am unable to get any sounds, even with the gm.map file and Midi files located properly in the /Plugins/Midiplayer folder. I do not get any errors in console.
     
  3. I get the same warning but it works fine for me. I put the gm.map file in the plugin's folder, and in the config I changed the default.map to gm.map for the map.

    ----

    I had some issues with some midis; some midis are silent and some midis play oddly; there seems to be a problem with midis that use multiple instrument/channels even though they are for the same kind of instrument.

    Death Waltz played brokenly but Bad Apple worked fine.

    Also sometimes the sound packs in the resource pack are too long and not suitable for the song.

    Some MIDIs play well while others don't; it's a hit or miss.

    But the ones that do play well make life worth living.

    This'll be the main feature of my server :D

    Waiting for the default map to be fixed; I'm really curious to hear what the songs will sound like with Minecraft sounds :D

    Sometime I might compile a list of MIDIs that play well.
     

    Attached Files:

    #63 poiihy, Dec 27, 2016
    Last edited: Dec 27, 2016
  4. The commands page mentions the midiplayer.play permission node for both playmidi and playglobalmidi, but I think playglobalmidi is supposed to have a different permission node. midiplayer.play doesn't enable use of playglobalmidi.
     
  5. When be fixed work without resource packs? :)
     
    • Agree Agree x 1
  6. console spams with metrics errors for midiplayer :\
    [​IMG]
     
  7. When playing files no sound ever plays and no error shows in console.

    Server Ver: 1.11.2
    Plugin Ver: 0..2.0

    Config: http://pastebin.com/m0byUaya
     
  8. Lol I forgot to update the sound mappings! sorry guys/gals!
     
    • Like Like x 1
  9. Nice, waiting update, don't work :/
     
  10. Things now play but when loading the plugin the console outputs 'Warning: No default drum' 'Drum Map File loaded' so I don't know if this is a real issue or not. But the updated sound mappings work :p

    Also, would you consider adding a volume command as well? :)
     
    #72 ObsceneNameHere, Feb 9, 2017
    Last edited: Feb 9, 2017
  11. Somes problems with drum ?

    Code (Text):

    2017-02-10 10:01:07 [INFO] [MidiPlayer] Instrument map file loaded.
    2017-02-10 10:01:07 [INFO] [MidiPlayer] Warning: No default drum.
    2017-02-10 10:01:07 [INFO] [MidiPlayer] Drum map file loaded.
    2017-02-10 10:01:07 [INFO] [MidiPlayer] Config loaded
     
    I have:
    default.drm
    default.map
    in midiplayer drawer :/

    I give a try with ressources pack, i put gm.map on directory, but no changes, just default sound.
     
    #73 belfedia, Feb 10, 2017
    Last edited: Feb 10, 2017
  12. Anything on the console? What version of minecraft are you using? What version of the mappings are you using?

    This plugin was a side project and a proof of concept that you can do such thing. I'll see what I can do in regards to the volume but no promises. For now you can change the max volume in the mapping file.

    The default drum is not an error. It only means that there is no default drum instrument defined in the mapping file (its by desing). The default drum is played when midi contains a drum that was not defined. Id its not set there will be silence.
     
    • Like Like x 1
  13. Hello, thanks for answer :)
    All is working good except Ressourcespack and gm.map,
    I use 1.11.2 server.
     
  14. How exactly (step by step) did you use the resource pack?
     
  15. Just put ressourcepack ( is'nt 1.11.2 rdy) in my minecraft, put gm.map in Midiplayer directory and try to /play a song.
     
  16. I assume that you enabled the resource pack. Did you also change the mapping file in the MidiPlayer config?
     
  17. #79 belfedia, Feb 13, 2017
    Last edited: Feb 14, 2017