Spigot MineconomicSystem 0.7

Simple Vault's Economy Implementation

  1. MasterCapeXD submitted a new resource:

    MineconomicSystem - Simple Vault's Economy Implementation

    Read more about this resource...
     
  2. Hello, I have a problem with your plugin, when i reload my server, the plugins doesn't load.

    This is a code error :

    :32:08] [Server thread/ERROR]: Could not load 'plugins/MineconomicSystem.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: Unsupported API version 1.15
    at org.bukkit.craftbukkit.v1_14_R1.util.CraftMagicNumbers.checkSupported(CraftMagicNumbers.java:261) ~[spigot.jar:git-Spigot-56f8471-3e3818b]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot.jar:git-Spigot-56f8471-3e3818b]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:334) ~[spigot.jar:git-Spigot-56f8471-3e3818b]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:253) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.loadPlugins(CraftServer.java:350) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.reload(CraftServer.java:808) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at org.bukkit.Bukkit.reload(Bukkit.java:576) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:27) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:149) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchCommand(CraftServer.java:710) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchServerCommand(CraftServer.java:695) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at net.minecraft.server.v1_14_R1.DedicatedServer.handleCommandQueue(DedicatedServer.java:430) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at net.minecraft.server.v1_14_R1.DedicatedServer.b(DedicatedServer.java:394) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:970) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:815) [spigot.jar:git-Spigot-56f8471-3e3818b]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_231]

    The plugin is compatible with 1.15 of spigot ?
    Can you help me ?
     
  3. Hello. Are you using the last version of MineconomicSystem? If not, try to download and put it into your plugins folder.
    Also I see this package path: org.bukkit.craftbukkit.v1_14_R1. Are you using 1.14.x server version? If so, you can open a .jar as archive and open plugin.yml file and replace api-version: 1.15 to api-version: 1.14. I've tried to run this plugin on 1.15 and it worked. There is no code that is unsupported on some versions and should work on a lot of versions.
     
    #5 MasterCapeXD, Jan 16, 2020
    Last edited: Jan 16, 2020
  4. Also I recommend to add load: STARTUP into plugin.yml. It will be fixed in a new version of plugin but currently you should do that.
    Correct plugin.yml for you
    Code (Text):
    name: MineconomicSystem
    main: me.mastercapexd.mineconomic.MineconomicPlugin
    version: 0.3
    load: STARTUP
    author: MasterCapeXD
    depend: [Vault]
    api-version: 1.14
    :
     
    #6 MasterCapeXD, Jan 16, 2020
    Last edited: Jan 16, 2020
  5. Привет, можешь добавить поддержку PlaceholderAPI для вывода баланса, к примеру, в ScoreBoard справа? Если можно, было бы замечательно вывести все три: SIMPLE, DECIMAL_ONE_CHAR, DECIMAL_TWO_CHARS.