Minecraft 1.11 Roadmap

Discussion in 'News and Announcements' started by md_5, Nov 9, 2016.

Thread Status:
Not open for further replies.
  1. I think Spigot should drop support for 1.7 and 1.8 and make people update. But people will still not update.
    • Agree Agree x 4
    • Like Like x 1
  2. md_5

    Administrator Developer

    We've dropped support for year(s).
    Doesn't stop people demanding it.
    • Agree Agree x 2
    • Like Like x 1
  3. Stop being salty about it.

    At least people are still using your programs even if it isn't the most updated.

    People still use 1.8-1.10 but due to the majority of servers being PvP oriented they use 1.7

    You need to chill out and think about the good side that people still are using your program.
    • Optimistic Optimistic x 3
    • Funny Funny x 2
    • Like Like x 1
  4. I am crazy. Remove it from being compiled in the Buildtools. Servers think it is smarter because it will get more players but. I don't join servers that are behind. Another reason people don't update is some Forge mods are not compatible with 1.10 or 1.11. Then there are the plugins some plugins are still in 1.7. or 1.8. But I hope people will realize it is stupid not to update.
    • Agree Agree x 6
    • Like Like x 1
  5. ?????????????????????????????
    You hella mad over something
    • Agree Agree x 10
    • Like Like x 1
  6. ssamjh


    Excuse me but who do you think you are talking to!
    You may not realize but the Minecraft community would not exist if it wasn't for @md_5 and his team salvaging it after the Bukkit's DMCA.

    Before you get all pissy at someone and call them salty, make sure you respect the people who have helped keep Minecraft alive since the DMCA to this day!

    ~Sam out
    • Agree Agree x 16
    • Winner Winner x 6
    • Like Like x 2
  7. Get over the pvp change!!!!!!!!!!!!!!! Who cares if you have to wait. Bukkit/Mojang add a way to disable the pvp wait time on newer versions. Via Java code.
    Don't. without @md_5 you would not have Spigot or Bungeecord.
    • Agree Agree x 6
    • Funny Funny x 2
    • Optimistic Optimistic x 2
    • Friendly Friendly x 1
  9. All hail the great and powerful @md_5 with his mighty sword of Java!
    • Funny Funny x 2
    • Like Like x 1
    • Creative Creative x 1
  10. You guys a great. ;)
    I would suggest perhaps discontinuing support for lower versions one at a time so people don't flip out.
    So, stop supporting 1.7 when 1.11 comes out, and when 1.12(?) or the next version comes out in the future, cut off 1.8. And perhaps 1.9 at the same time as well (considering if you're running 1.9, you may as well go for 1.10)
    This gradual change will help prevent server owners from feeling like they're being treated unfairly and allow you guys to take some weight off your backs.

    1.8 will be the most difficult thing to drop, since many people rely on it mainly do to the combat system. :eek:
    Here's what I don't get about that, there are plugins which edit the attack speed and damage of weapons so they're like 1.8 mechanics.
    so why not upgrade?
    I for one love the new 1.10 API
  11. I updated to 1.10 3 months after it was released. The reason for waiting that long was simple: Plugins that I needed had not updated. We all know the issue exists, plugin developers don't really want to keep their plugins up to date. So IMO, that's why most servers don't upgrade.

    But in the end, it's really laziness. For example: ChestCommands is not compatible with 1.10. However if you download the code and fix it yourself it only takes 5 minutes to update! And it's not as if Filoghost isn't arround, he's released 2 updates for HologramDisplays 1.10!

    But I know there's no easy way to fix that issue, changes have to be made. But major ones, such as the sound name changes In 1.11 really mess things up. So if you really want people to update, you should try making it more cross version compatible!

    But of course... Let's not forget about NMS :p

    I will updated my first and only plugin ASAP, right when 1.11 releases.

    Thank you for the continuous support. You're the one that's keeping the Minecraft Server community alive!

    EDIT: About the PvP issue. Yeah, it's a controversial change, but with the fix of the one tick delay issue when hitting in 1.11 and all the great items that have been added to enhance the PvP experience, it's safe to say that upgrading is a great idea. Just add a plugin or develop one yourself (did that, it was easy)!
    • Informative Informative x 2
  12. You guys are awesome! I'll always update as soon as all my plugins are ready for it, so it sometimes takes several weeks, but I always want to present my players the new features asap.
    I think a lot of server owners are still running 1.8 because the community doesn't like the new pvp system. Although there are ways using the old pvp system in 1.9+, they simply can't convince their players, because a lot of kids are thinking "1.9? Never. Shitty PvP!". And unfortunately a lot of networks have this target group.

    Is there any tool that automatically updates plugins nms references? Like this BuildTools-Command that updated the old getonlineplayers() method?

    (Sorry, English is not my mother language.)
    • Agree Agree x 1
  13. Thanks to all the spigot team for their work, I can't wait to update my server with the new version!
    You do a great job keep it going like that! The whole community supports you!
    • Like Like x 2
    • Agree Agree x 1
    • Friendly Friendly x 1
  14. Oh, yeah good point.
    I didn't have to update ChestCommands though, it works fine for me on 1.10 funny enough, and yeah, most of the time it isn't very difficult to upgrade plugins even if it means sacrificing a feature or two if you can't recreate it.
  15. Choco


    You'd be surprised. It's getting to the point where 1.10 mod packs are constantly being released. Mods are finally moving up to 1.10 because of new developers, and old developers found initiative and motivation to finally update to all the new rendering changes that Mojang's made in 1.8.

    I suggested this in my reply there, and it's something I've been doing since I became a plugin developer. I always support the latest version and the one before it, (1.10 and now 1.11, dropping support for 1.9), in the case that people did not have time or motivation to update yet. I highly recommend this idea as it works flawlessly for me. I have yet to see someone complain to me that my plugin does not work on 1.8 because I make it publicly aware that I do not support older versions
    • Agree Agree x 1
  16. That's still more than 30,000 servers running 1.10.2 though, the 2nd highest version to 1.8.8 which I don't think server owners will be switching from anytime soon.

    Spigot is all about customizing Minecraft with plugins and mods, it's up to those developers to keep things up to date. Don't blame server owners for not upgrading when doing so could potentially ruin their setup.

    You've got an incredible community here with a lot of support. We all appreciate the work you do even if some of us are still running a bit behind. Personally, I will probably wait a month to upgrade my server to 1.11.

    Thanks for the update :)
    • Like Like x 1
  17. electronicboy

    IRC Staff

    > implying that the 1.9 PvP changes are just a difference in the delay.

    There are dozens of changes in 1.9 that affected PvP, if it was just the tick delay that was changed, it wouldn't be an issue, the thing is that the way attacking feels in the client was changed, even with the tick delay changed to a value that doesn't seem to have an effect, the whole feel to PvP just feels bloated. Yes, there are plugins that help with dropping down the impact of the changes, in fact I ended up telling one of the mostly used plugins how to fix a massive performance issue in their plugin, so; I know that some decent-ish plugins that do this are already out there.

    My official stance is, Upgrade to 1.11 when it's released and your plugins are available. Support for versions like 1.10 will slowly fade out, especially when Spigot hits 'latest' ready which is likely to be a week or two, or possibly even longer due to the size of changes on 1.11, based upon recent trends, any new bugs that surface unless major security issues will not see a fix.
    Heck, within 2 minutes of seeing the draft for this post, 2 people joined the channel expecting help for a bug with 1.8 that was already fixed in 1.10, as well as somebody else expecting a new plugin made for 1.9+ not working on 1.8, so you can see why Spigot really hates the fact that 1.8 is still lingering.

    My personal stance is that if you wanna run 1.7 or 1.8, do so; Just don't come complaining and asking for help when there is a bug and nobody wants to help you, if you're running outdated software, you should be capable of supporting yourself. and this concept isn't a Spigot only thing, this concept is employed around the whole software industry, it's very rare a company will support their software after it's hit EOL.

    removing versions of spigot from compiling easily in buildtools really doesn't solve anything, it would be super trivial to write a script that compile the latest version of buildtools that would run in bash without any issues, especially as the script doesn't even need to care about changes to the repo as they don't exist. All changes are still in the repo, that's how git works, anybody with basic knowledge of java can easily follow how buildtools works, anybody with a reasonable amount of knowledge of git could compile any version they wanted from that repo.

    Plugin developers being lazy is a horrible issue that is just the way projects like this go, when I was running a server which I'm currently in the middle of finding time to setup again, the number of plugins that I saw that had just been dropped was astonishing, plugins like vineyards, I ended up having to take apart and upgrade myself, just so they would work fine. and while in some cases that was nice, especially in cases where I could actually improve the way the plugin worked, however for most server owners who can't develop plugins, I can imagine stuff like that is total hell, especially when critical plugins don't update and effectively hold them back.
    • Agree Agree x 3
    • Like Like x 1
  18. Very nice!
    • Like Like x 1
  19. MiniDigger


    nobody should support old versions anymore. if we developers develop nice stuff on newer versions that ppl want to use they will be forced to upgrade. if you maintain old stuff, they don't see why they should upgrade .
    • Agree Agree x 1
  20. We don't update cause we don't like 1.9 pvp dynamics.
    • Optimistic Optimistic x 3
    • Agree Agree x 1
    • Informative Informative x 1
Thread Status:
Not open for further replies.