Minecraft 1.11 Roadmap

Discussion in 'News and Announcements' started by md_5, Nov 9, 2016.

Thread Status:
Not open for further replies.
  1. I hope you will still support 1.8 until 1.11 for bungeecord.
    If it is, I can update my servers one for one to 1.11 so I have the time for searching plugin updates or making my own alternatives.
    Else I must keep the 1.8->1.10 bungeecord and I cant update to 1.11 o_O

    Such as a lot of people said above, the players don't want to update so if you use something like viaversion you can give your players time to make the step to 1.11

    I hope there will be some extra nice api methods in spigotmc that makes the development easier :cool:

    Anyway, thank you for making spigot!
     
  2. And there are peoples still using 1.7.10.




    Amazing
     
    • Funny Funny x 1
    • Optimistic Optimistic x 1
  3. Many of them are on modded servers. I try and maintain support back to 1.7.10, and modded servers are those that request it.
     
    • Agree Agree x 1
  4. So, in short, make it so that 1.8 doesn't work anymore, then force everyone to update! Just saying...
     
    • Like Like x 1
  5. electronicboy

    IRC Staff

    Because that's practically impossible to do... if you wanna try to act smart, at least know what you're talking about.
     
  6. Spigot doesnt support mods and plugin at same time.
     
  7. I never said it did. Most of the time when people are still on 1.7.10, it's because of mods. The people still on 1.8 are usually because of the PVP changes. I'm not sure why ~7.4% of Bukkit servers are still on 1.9 versions. Now that's a mystery to me.
     
    • Agree Agree x 1
  8. I'm still running Craftbukkit 1.8.8. The problem is that some of the most important plugins I use haven't been updated. So the lowest common denominator is really plugin-related; if there's even just one plugin that only works up to 1.8.8, that's the version I have to run.

    Good news for md_5 is that I don't need any support from Spigot. Further good news is that my server is very stable. I haven't made any changes to the server .jar or plugins in 8 months.
     
  9. Just a friendly FYI most plugins will work on multiple versions so a 1.8 plugin can work on 1.10
     
  10. i9hdkill

    i9hdkill Retired Moderator
    Retired Supporter

    Seriously, because of a single plugin? We have many talented people on spigot, ask them and they might help you!
     
    • Agree Agree x 1
  11. Mikgreg

    Supporter

    I really do want to update to 1.10-11 quite a lot, but doing so would lose me 60%+ of my players, which i'm not prepared to do. Mojang need to accept they fucked up and revert their pvp changes.
     
    • Agree Agree x 2
    • Optimistic Optimistic x 1
  12. good roadmap
    me likey
     
  13. It's more than one plugin. There are multiple plugins that are either completely broken, partially broken, or not updated in 2 or 3 years (so I don't know if they will work or not). Just a short list off the top of my head: Cube Genetics, Infinity Dispensers, Mob Arena, Motd Manager; Multiverse Inventories, Player Heads, Plot Me, Prism, not to mention a couple custom plugins of my own. And even if they do work, I have to test them first.

    TL;DR: It's not worth my time to test 40 plugins to see if they work with newer versions of Craftbukkit/Spigot. I have a set that works with 1.8.8.
     
  14. i9hdkill

    i9hdkill Retired Moderator
    Retired Supporter

    99% of them work 100% with 1.10. Just setup a dev server and test them. Costs 15 minutes of work and you can update to 1.10.
    You can private message me if you need further help or advices or open a topic in spigot plugin help if you need help with it.
     
  15. It's a hell of a lot more than 15 minutes of testing. Takes more than 15 minutes just to find and download the new versions. And like I said, some of them are broken and won't work anyway.
     
  16. i actually want to update to 1.10 but do you guys have any recommendation to plugins that revert to 1.8 mechanics for pvps? thanks
     
  17. Here! It works out of the box too.
     
  18. I know. I was just trying be a smart-a**. No one put in a safe-gaurd to stop Spigot Servers.
     
  19. their discussion players say there's bugs about duping and such and the dev hasn't updated it so not sure if i should use it.
     
  20. i9hdkill

    i9hdkill Retired Moderator
    Retired Supporter

    I know that I am one of the guys that brought the topic a bit offtopic, but please try to stick to the topic from now on.
     
Thread Status:
Not open for further replies.