Minecraft - LWJGL for Mac OS X 10.7.5 or update to 10.9 without slowing it down?

Discussion in 'Gaming Lounge' started by bys1, Jul 17, 2018.

  1. Minecraft requires the LWJGL library to work. With 1.13, they updated to LWJGL 3, which apparently doesn't support anything below 10.9. I have a 13-inch MacBook 7,1 from mid 2010 and upgraded my RAM from 2 to 8 GB. It was originally on Mac OS X 10.6.4 and later upgraded to Mac OS X 10.7.5 which I'd like to keep. Is there any way to get LWJGL running on 10.7.5?

    The other solution is to upgrade to Mac OS X 10.9. However, a friend has the exact same Mac as I have (however still with 2 GB RAM) and also upgraded, and that mac become very slow after upgrading. Can I somehow upgrade my Mac without slowing it down? I can't afford to buy a new one...