Premium MineSecure [Paid]

Discussion in 'Resource Discussion' started by md_5, Jun 29, 2014.

  1. Would it be possible to implement disabling certain messages by setting the string to
    Code (YAML):
    remembered: ''
    At the moment it just sends a blank line.

    EDIT:

    I'd also really love to see a cooldown on the "You must enable/enter 2FA" messages when moving around (ie. it wouldn't send a warning if one has already been sent in the last 20 ticks). It's not a big deal, but would be a nice bit of polish.
     
    #621 TivyHosting, Mar 3, 2020
    Last edited: Mar 3, 2020
  2. md_5

    Administrator Developer

    Yeah that's an issue with priorities or code in the other plugin
     
  3. Sorry for the post spam, but you already replied to my previous, so I figured I should post another. As documented it appears that the Bungee command disabling only works with 1.14 Spigot. It's necessary to have this fixed for us to be able to use the system on our 1.12.2 servers (1.15 Bungee).

    We are happy to contribute code for this fix if that would help (but at the moment it is closed source so no way for us to do so). :)
     
  4. Does this work for 1.15.2 Spigot?
    If so I'll buy this in a heartbeat.
     
  5. md_5

    Administrator Developer

    Yes
     
  6. Well finally got to record this issue

    Here is the external view & player view. They are not clicking anything on there keyboard/mouse and have to re-join to fix the issue.

    External:

    Player View:
     
  7. So this still doesn't work with bungee if your Spigot is not 1.14.4?

    any update on this?
     
  8. Players are not getting a map? Latest 1.15.2
     
  9. md_5

    Administrator Developer

    Latest is not a version
     
  10. andrewkm

    Patron ⭐⭐⭐

    @md_5

    I can confirm there are issues with getting a map.
    (The map message is shot onto the player, but no map is provided).
    Spigot, Bungee, Minesecure (1.3.1). All latest as of this post.

    I hate reporting issues that are this vague, and always find the culprit, but this one legit is a one of a kind. I have spent hours, and I'm just about done. I'm left with no option but to report "maps are not given to players on some servers". That's literally it lmao.

    Have removed plugins.
    Have tested on bare bones setups.
    Have gone through minesecure versions, spigot builds, bungee builds, you name it, it's been done.
    4x dedis. Several servers on each. Some are identical setups. Identical 1: will give a map. Identical 2: will not give a map.

    The only thing I've been able to confirm is that 1.12.2 servers are not affected, meanwhile 1.15.2 servers are hit and miss. (Then again I may simply not have enough 1.12.2 servers to eventually replicate a broken environment on.)

    Please provide some sort of debuging fucntionality/capability so I can get to the bottom of this.
    Again, I know straight up how this report looks, and I hate making these, but I literally have no choice. Some voodoo is definitely going on...

    EDIT: I believe I'm finally getting somewhere, will report back shortly.
     
    #630 andrewkm, Apr 2, 2020
    Last edited: Apr 2, 2020
    • Like Like x 1
  11. andrewkm

    Patron ⭐⭐⭐

    @md_5

    Alright, got it.
    When a user uses the /2fa command a map_<#>.dat file is generated in <world>/data folder.
    Eventually the amount of map_<#>.dat files is so numerous that maps no longer generate for the player in game.

    To fix this issue one must delete their <world>/data/idcounts.dat file.
    A fix would be appreciated on your end if possible.

    Unfortunately I do not have the time to check after how many maps it stops working exactly. Personally I was all the way at map_137.dat (although each failed attempt generated a new map_<#>.dat file).

    Cheers!

    PS: Guess I lied when I said identical, I did not think to go this deep into it lol.
     
    #631 andrewkm, Apr 2, 2020
    Last edited: Apr 8, 2020
  12. md_5

    Administrator Developer

    What version of Spigot?

    See:

    Doesn't seem like an issue with this plugin or Spigot to me
     
  13. andrewkm

    Patron ⭐⭐⭐

    @md_5

    Code (Text):
    [19:42:22] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-a03b1fd-bbe3d58 (MC: 1.15.2) (Implementing API version 1.15.2-R0.1-SNAPSHOT)
    As mentioned, I have tested on all latest, and now as of this post, Bungee, Spigot, Minesecure.
    (I am a paper user indeed, but for the sake of bare bones testing, I am doing so on Spigot of course).
    This is 100% a bug, I can send you the <world>/data folder so you can examine. Please let me know which way you'd like to receive if needed.

    The only solution is stated in my previous post, deleting <world>/data/idcounts.dat
     
  14. He is not gonna give you support when using another version of spigot, so it is useless to report bugs to him.
     
  15. andrewkm

    Patron ⭐⭐⭐

    The bug exists for Spigot itself, it is not a bug related to any Spigot fork. As such should be addressed and fixed (hopefully).
    Given that map IDs are finite, ideally should stick to using one ID if possible. Generate enough /2fa maps and this issue occurs.
     
    #635 andrewkm, Apr 3, 2020
    Last edited: Apr 3, 2020
    • Agree Agree x 1
  16. I get an empty map without a code, thermos 1.7.10
    Please, help.
    upload_2020-4-5_22-36-55.png
     
  17. Hi.
    Would you like to add the configuration option for IP Remembering?
     
  18. md_5

    Administrator Developer

  19. md_5

    Administrator Developer

    Should be fixed
     
    • Winner Winner x 1
  20. andrewkm

    Patron ⭐⭐⭐

    Confirmed fixed via previously broken environment.
    Thank you!