Spigot Moar Bows 2.6

Add 25+ unique bows to your server!

  1. Are you gonna add customs textures to bows ?
     
  2. You can do this by setting durability values to bows & by using a custom resource pack
     
  3. That's not what I was asking for, excuse me, I just tell you that if you was adding this to the plugin it will be cool, but thx for help :)
    If you want more ideas for bows, you can ask me ;)
    PS: Very Good Plugin
     
    #243 Super_cube4, Jan 30, 2019
    Last edited: Jan 30, 2019
  4. I have errors like this:

    [12:03:53 ERROR]: com.sk89q.worldguard.bukkit.WorldGuardPlugin.getFlagRegistry()Lcom/sk89q/worldguard/protection/flags/registry/FlagRegistry; initializing MoarBows v2.4.2 (Is it up to date?)
    java.lang.NoSuchMethodError: com.sk89q.worldguard.bukkit.WorldGuardPlugin.getFlagRegistry()Lcom/sk89q/worldguard/protection/flags/registry/FlagRegistry;
    at net.Indyuce.moarbows.comp.worldguard.WorldGuardOn.<init>(WorldGuardOn.java:24) ~[?:?]
    at net.Indyuce.moarbows.MoarBows.onLoad(MoarBows.java:49) ~[?:?]
    at org.bukkit.craftbukkit.v1_13_R2.CraftServer.loadPlugins(CraftServer.java:330) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at net.minecraft.server.v1_13_R2.DedicatedServer.init(DedicatedServer.java:213) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:698) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_191]

    and


    [12:04:02 ERROR]: Error occurred while enabling MoarBows v2.4.2 (Is it up to date?)
    java.lang.NullPointerException: null
    at net.Indyuce.moarbows.MoarBows.onEnable(MoarBows.java:55) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:265) ~[spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:347) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:410) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugin(CraftServer.java:436) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugins(CraftServer.java:350) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at net.minecraft.server.v1_13_R2.MinecraftServer.l(MinecraftServer.java:580) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:542) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:420) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at net.minecraft.server.v1_13_R2.DedicatedServer.init(DedicatedServer.java:294) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:698) [spigot-1.13.2.jar:git-Spigot-f09662d-f40143e]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_191]
     
  5. Make sure you are using the very latest WorldGuard version available for your server, WG 7.0 at least
     
  6. I`m sure. worldguard-legacy-7.0.0-beta-03. Still not working.
    Oh well... :(


    [12:05:04 ERROR]: Error occurred while enabling MoarBows v2.4.2 (Is it up to date?)
    java.lang.NullPointerException: null
    at net.Indyuce.moarbows.MoarBows.onEnable(MoarBows.java:55) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:265) ~[spigot-1.13.2.jar:git-Spigot-f09662d-7c395d4]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:347) [spigot-1.13.2.jar:git-Spigot-f09662d-7c395d4]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:410) [spigot-1.13.2.jar:git-Spigot-f09662d-7c395d4]
    at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugin(CraftServer.java:436) [spigot-1.13.2.jar:git-Spigot-f09662d-7c395d4]
    at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugins(CraftServer.java:350) [spigot-1.13.2.jar:git-Spigot-f09662d-7c395d4]
    at net.minecraft.server.v1_13_R2.MinecraftServer.l(MinecraftServer.java:580) [spigot-1.13.2.jar:git-Spigot-f09662d-7c395d4]
    at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:542) [spigot-1.13.2.jar:git-Spigot-f09662d-7c395d4]
    at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:420) [spigot-1.13.2.jar:git-Spigot-f09662d-7c395d4]
    at net.minecraft.server.v1_13_R2.DedicatedServer.init(DedicatedServer.java:294) [spigot-1.13.2.jar:git-Spigot-f09662d-7c395d4]
    at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:698) [spigot-1.13.2.jar:git-Spigot-f09662d-7c395d4]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_191]
     
    #246 LCobra, Apr 9, 2019
    Last edited: Apr 9, 2019
  7. Are you using latest spigot build, you didn't compile it yourself did you? Also try updating your java
     
  8. Get this error, the same as @LCobra @Indyuce


    [23:32:57] [Server thread/ERROR]: Error occurred while enabling MoarBows v2.4.2 (Is it up to date?)
    java.lang.NullPointerException
    at net.Indyuce.moarbows.MoarBows.onEnable(MoarBows.java:55) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot-1.8.8-R0.1.jar:git-Spigot-e4d4710-e1ebe52]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot-1.8.8-R0.1.jar:git-Spigot-e4d4710-e1ebe52]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.8.8-R0.1.jar:git-Spigot-e4d4710-e1ebe52]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) [spigot-1.8.8-R0.1.jar:git-Spigot-e4d4710-e1ebe52]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) [spigot-1.8.8-R0.1.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414) [spigot-1.8.8-R0.1.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378) [spigot-1.8.8-R0.1.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333) [spigot-1.8.8-R0.1.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263) [spigot-1.8.8-R0.1.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot-1.8.8-R0.1.jar:git-Spigot-e4d4710-e1ebe52]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_91]

    The plugins works perfectly fine on my localhost server, as soon I move the MoarBows jar and folder over to my VPS that is using the same spigot.jar as my localhost, I get this error.
     
    #248 DavidVioMC, Apr 17, 2019
    Last edited: Apr 17, 2019
  9. Make sure there's no other console error log from MoarBows, there has to be some compatibility issue because MoarBows can't load fine.. I have no error on my end with WG beta 3 and WE beta 5
     
  10. I was running WG beta 3 aswell and WE 6.1.9. I didn't have WE on my test server where MoarBows worked fine, after copying WE onto my test server, I got the same error and MoarBows failed to load which is going to cause an issue.

    I'm running 1.8.8 server and MoarBows has been tested on 1.8 and I know it works but the last WE version that supports 1.8.8 is WE 6.1.9 which is up to 1.12.2, WE beta 1 to 5 only supports 1.13, at least on paper. I think you should modify or update MoarBows to also works with WE 6.1.9 since that's the last version of WE that supports 1.8 to 1.12. Right now MoarBows only works on 1.13 if the server has WE.

    EDIT: Just tested, WE Beta 1 to 5 does not work on server 1.8, MoarBows needs to be updated to work with WE 6.1.9 so MoarBows can be used on 1.8 to 1.12 servers.
     
    #251 DavidVioMC, Apr 19, 2019
    Last edited: Apr 19, 2019
  11. There are two versions for MoarBows. The 1.13 version uses 1.13 WE & WG API. The legacy version uses WG 6.2 and WE 6.1.9 API which is compatible with 1.8. Are you using the right version? Can you upload your server logs so I can check for compatibility issues?
     
  12. @Indyuce This plugin is really amazing but is there away to make the bows act as a normal enchant rather than the name and lore based? like a lore with 'explosive bow' would give the bow the enchant effect?
     
  13. You can't do that, bows are based on a NBTTag
     
  14. Any chance to add a lore based option?
     
  15. Not a fan of that option.. checking NBTTags is much easier
     
  16. That's a shame. Your plugin has a lot of unique things. Suppose I'll revisit it some time later
     
  17. Oh I think I misunderstood what you meant. Did you mean a way to create custom bows by adding one line in the lore which looks like an enchant like `&7Summon Meteor I` for the meteor bow? That could be an interesting feature since you can make the bow power depend on the enchant level.
     
  18. Yes, but also identified by that enchant lore so you can these to mob drops like mythic mobs.
    Maybe add a config option to identify as the lore instead of NBT tags with a warning of it being easily exploitable or whatever