Solved Mobcoins errors in console ( in need of quick help )

Discussion in 'Spigot Plugin Help' started by wilmzor, Apr 3, 2020.

  1. So im developer on a Factions server and there is alot of issues in the console regarding the mobcoins plugin im in need of quick help! I think ther eis some plugin blocking it but i cant find any plugin called InventoryCreativeEvent. Please help! here is the console:





    >.... [19:19:24 ERROR]: Could not pass event InventoryCreativeEvent to MobCoins v4.6
    java.lang.NoSuchMethodError: org.bukkit.inventory.Inventory.getTitle()Ljava/lang/String;
    at com.peaches.mobcoins.Events.OnInvClick(Events.java:29) ~[?:?]
    at com.destroystokyo.paper.event.executor.MethodHandleEventExecutor.execute(MethodHandleEventExecutor.java:37) ~[patched_1.14.4.jar:git-Paper-237]
    at co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:80) ~[patched_1.14.4.jar:git-Paper-237]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:70) ~[patched_1.14.4.jar:git-Paper-237]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:545) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.PlayerConnection.a(PlayerConnection.java:2470) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.PacketPlayInSetCreativeSlot.a(SourceFile:23) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.PacketPlayInSetCreativeSlot.a(SourceFile:9) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.PlayerConnectionUtils.lambda$ensureMainThread$0(PlayerConnectionUtils.java:23) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.TickTask.run(SourceFile:18) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandler.executeTask(IAsyncTaskHandler.java:136) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandlerReentrant.executeTask(SourceFile:23) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandler.executeNext(IAsyncTaskHandler.java:109) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.MinecraftServer.aX(MinecraftServer.java:1029) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.MinecraftServer.executeNext(MinecraftServer.java:1022) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandler.awaitTasks(IAsyncTaskHandler.java:119) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.MinecraftServer.sleepForTick(MinecraftServer.java:1006) ~[patched_1.14.4.jar:git-Paper-237]
    at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:929) ~[patched_1.14.4.jar:git-Paper-237]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_242]
     
  2. The Plugin tries to run the getTitle() Method but your server doesn’t provide that method.
    It looks like the plugin was coded for a legacy version of Minecraft as in 1.8 the Method is called getName() and in 1.15 it’s called getTitle()
    You should contact the plugin developer to get a fix for this.
     
  3. Hmm maybe i should but i think its a plugins whos blocking it becuase it works fine in the Skyblock server. Idk
     
  4. Do they use the same spigot version?
     
  5. I do not think so, I think ive solved the problem, my other developer friends have done something wrong with the Viaversion and stuff, instead of going 1.8.8 and up they did 1.14.4 and down which often does not work so good.
     
  6. Did it work now?
     
    • Like Like x 1
  7. Yeah thank you mate! have a good day.
     
    • Like Like x 1
  8. You too good luck with your server