Mobs won't spawn

Discussion in 'Spigot Plugin Help' started by Birkhoff, Apr 14, 2017.

  1. Hey there. As the title says, no mobs or animals are spawning in my Skyblock world (ASkyblock)

    Here's my full list of plugins:

    Plugins (70): KeepItems, ClearChat, PlaceholderAPI, NametagEdit, PingPlayer, PandaWire, GiveMeBackMyLava, Ingot, DeluxeTags, AutoRestart, TradePlus, ChatColor, LuckPerms, BlockCreator, HungerKeeperPlus, AnimatedScoreboard, AutoSmelt, ClearLag, AutoMessage, WorldBorder, Votifier, AutoSaveWorld, NightVision, FastAsyncWorldEdit, DeluxeMenus, SuperbVote, mcMMO, SkyblockOres, Vault, TokenManager, ProtocolSupport, BottledExp, EpicRename, AuctionHouse, ASkyBlock, ChestCommands, AdvancedKitsReloaded, BungeeTabListPlus, WorldEdit, Essentials, SpigotLib, LiftSign, Banknotes, ProtocolLib, Multiverse-Core, VoidSpawn, DeluxeChat, LibsDisguises, Citizens, eZProtector, PAC, MobArena, HolographicDisplays, KillerMoney, WorldGuard, BungeePortals, LockettePro, EssentialsProtect, PluginBlock, Shop, CommandNPC, EssentialsSpawn, CratesPlus, RedstoneClockPreventer, MobStacker2, CommandRegions, LiteBans, SilkSpawners, ChestShop, CrazyEnchantments

    Any help will be appreciated. Thanks.
     
  2. Hi, I can see your server.properties?
    Code (Text):
    #Minecraft server properties
    #Sun Apr 09 21:26:22 CEST 2017
    spawn-protection=0
    generator-settings=
    force-gamemode=false
    allow-nether=true
    gamemode=0
    broadcast-console-to-ops=true
    enable-query=false
    player-idle-timeout=0
    difficulty=1
    spawn-monsters=true #(This is not set to false?)
    op-permission-level=4
    resource-pack-hash=
    announce-player-achievements=false
    pvp=true
    snooper-enabled=true
    level-type=DEFAULT
    hardcore=false
    enable-command-block=false
    max-players=20
    network-compression-threshold=256
    max-world-size=29999984
    server-port=#####
    debug=false
    server-ip=
    spawn-npcs=true
    allow-flight=false
    level-name=world
    view-distance=10
    resource-pack=
    spawn-animals=true #(This is not set to false?)
    white-list=false
    generate-structures=true
    online-mode=true
    max-build-height=256
    level-seed=
    use-native-transport=true
    motd=A Minecraft Server
    enable-rcon=false

    Or it may be a file world.yml the multiverse core folder.
    Code (Text):
    worlds:
      world:
        seed: -180168958178518248
        environment: NORMAL
        type: NORMAL
        hidden: false
        alias:
          name: ''
          color: WHITE
        pvp: true
        scale: 1.0
        respawnworld: ''
        allowweather: true
        difficulty: EASY
        animals:
          spawn: true #(This is not set to false?)
        monsters:
          spawn: true #(This is not set to false?)
        entryfee:
          currency: -1
          price: 0.0
        hunger: true
        autoheal: true
        adjustspawn: true
        portalform: ALL
        gamemode: SURVIVAL
        keepspawninmemory: true
        spawn:
          x: -184.5
          y: 64.0
          z: 79.5
          pitch: 0.0
          yaw: 0.0
          world: world
        autoload: true
        bedrespawn: true
     
    #3 Werwicz, Apr 14, 2017
    Last edited: Apr 14, 2017
  3. Just gonna spit out some ideas/questions here from the top of my head.
    Is your doMobSpawning gamerule set to true? Does your global WorldGuard region allow mob spawning? Maybe your mob stacker plugin is preventing mobs from spawning properly. Does your console have any errors when a mob is attempting to spawn? Can you spawn in mobs successfully via /spawnmob (or other relevant command)? Try removing any plugin that influences mobs in any way one at a time, and see if you can pinpoint the issue.
     
  4. doMobSpawning gamerule was set to true; WorldGuard thingy enabled; tried deleting stacker plugin but no use; no error; I can spawn via /spawnmob

    I found that the mobs are actually spawning, but slow af
     
  5. Here's some information about how to edit mob spawn rates via Multiverse-Core. Your values of -1 in worlds.yml signify that you are using the default spawn rate, which should normally be just fine. You can also edit the spawn limits in bukkit.yml, explained here. You would want to raise the number instead of lowering it, though.
    I did some googling to find the above information, so pardon me if it ends up not being helpful or fully correct.
     
  6. I'm having a similar issue.
    So, sorry if this is considered spam but I could not find any other information on Google that was related to this and this thread was just here. So, my problem is that mobs are not spawning at all. Inside of my action bar health viewer thing, when you hover over an entity it shows the health of the entity but you cannot see and interact with the entity(such as hurting it). I cannot spawn any mob but the chat message shows as a success. The entity is still registered (kind of). The shadow does not show, it shows nothing in F3, but it still makes a sound. You cannot see the player's nametags, as players are the only entities that show. My WorldGuard region allows mob spawning, I have no stacker plugin, I also have the doMobSpawning gamerule set to true. What can I do?