1.17.1 module 'spigot' is unstable

Discussion in 'Spigot Plugin Development' started by Foxelz05, Nov 25, 2021.

Thread Status:
Not open for further replies.
  1. Hi!
    So i am getting a warning from eclipse and i have already tried everything i have found out there about this error but for some reason the warning is still there.
    Here is the warning

    "Name of automatic module 'spigot' is unstable, it is derived from the module's file name."
     
  2. Maybe try reinstalling Eclipse or Spigot?
    I'm an IntelliJ user, so I don't really know.
     
  3. Can you provide more information?
     
  4. The warning is coming from the module-info.java
     

    Attached Files:

  5. md_5

    Administrator Developer

    Spigot doesn't really support modules (module-info). Is there a reason you need a module-info, if not, just delete it.
     
  6. Thanks!
     
Thread Status:
Not open for further replies.