Moving from 1.8.4 vanilla to 1.8.3 Spigot/CraftBukkit

Discussion in 'Spigot Help' started by Wilberf0rce, May 11, 2015.

  1. I hope this isn't a duplicate question or posted in the wrong area. If it is, I apologize. I'm new here and I searched, but couldn't find the answer to my question, so I thought I'd post =o)

    I currently run a vanilla Minecraft 1.8.4 server with a host that has a JAR selection menu where I can choose Spigot 1.8.3 or CraftBukkit 1.8.3. Back in the 1.6.4 days, I played on a Bukkit server, but I never set it up. This is my first time trying to convert a vanilla world to a Bukkit/Spigot world and I need some advice/help.

    1.) Can I simply choose one of those and restart my server and it will be upgraded? Again, I've looked for more information on this both here and with my host, but I haven't found anything helpful for someone new to all this.

    2.) What's the difference between CraftBukkit and Spigot now? I'm hoping to add /warps to my world as well as some anti-griefing tools. Any direction with which way to go would be greatly appreciated!

    Thanks in advance for any help or guidance =o)
     
  2. Select new jar, it will convert.
    1.8.4 vanilla IS 1.8.3 spigot. Md_5 is just that way and wanted to fix security issues before Mojang does.

    If you need plugins and how to setup pm me.
    If you need to modify your spigot.yml which is created pm me.

    Spigot is an optimized bukkit.

    Get 1.8 essential, 1.8 world edit/guard and I can easily set up your stuff for you!
     
  3. Wow! Thanks for the fast reply and offer of personal help! :D I'm new enough that I can't PM yet, but I appreciate the offer! I'm going to make my backup now and then I'll select the new jar and post here if I have any issues =o)

    Thanks again!
     
  4. Okay, I have Spigot 1.8.3 R0.1 selected and I can log in, but I'm unsure where I get the 1.8 essential plugin... there is a bukkit plugin section with hundreds (thousands?) to choose from with install buttons, but I don't see "1.8 essential". I tried installing "Essential", but it gave errors when I logged in - I think it's an old plugin. Again, any help would be much appreciated, thanks! =o)
     
  5. Ahh ok, just post your skype here and asoon as i see it you can remove it.