Multicraft daemon error

Discussion in 'Systems Administration' started by sekin, May 27, 2020.

  1. Hello this is my first post,

    i have a server with a hosting company and i have a bungee network and i have issues with the lobby
    so the lobby server is up and i can connect to it and everyone can join, but in the multicraft panel the server is offline and when i try to start it i get



    27.05 09:40:27 [Multicraft] Loading server properties
    27.05 09:40:27 [Multicraft] Starting server!
    27.05 09:40:27 [Multicraft] Loaded config for "Spigot"
    27.05 09:40:27 [Multicraft] Updating eula.txt file
    27.05 09:40:28 [Server] INFO Loading libraries, please wait...
    27.05 09:40:32 [Server] INFO Starting minecraft server version 1.8.8
    27.05 09:40:32 [Server] INFO Loading properties
    27.05 09:40:32 [Server] INFO Default game type: SURVIVAL
    27.05 09:40:32 [Server] INFO This server is running CraftBukkit version git-Spigot-db6de12-18fbb24 (MC: 1.8.8) (Implementing API version 1.8.8-R0.1-SNAPSHOT)
    27.05 09:40:33 [Server] INFO Debug logging is disabled
    27.05 09:40:33 [Server] INFO Server Ping Player Sample Count: 12
    27.05 09:40:33 [Server] INFO Using 4 threads for Netty based IO
    27.05 09:40:33 [Server] INFO Generating keypair
    27.05 09:40:33 [Server] INFO Starting Minecraft server on 188.40.185.194:25563
    27.05 09:40:33 [Server] INFO Using epoll channel type
    27.05 09:40:33 [Server] WARN **** FAILED TO BIND TO PORT!
    27.05 09:40:33 [Server] WARN The exception was: java.io.IOException: Error during bind(...): Address already in use
    27.05 09:40:33 [Server] WARN Perhaps a server is already running on that port?
    27.05 09:40:33 [Server] INFO Stopping server
    27.05 09:40:33 [Server] INFO Saving players
    27.05 09:40:37 [Server] INFO [INFO] MC server teminated. Exiting...
    27.05 09:40:38 [Multicraft] Server shut down (starting)
    27.05 09:40:38 [Multicraft] Restarting crashed server in 30 seconds




    what should i do because i contacted the company they changed the port and server ip and same problem
     
  2. Daemon errors are always the hosts issues. I get those a decent amount as well but they typically resolve them fast. But yeah Daemon errors are their fault and not much you can do about them
     
  3. Hi, this definitely seems like it's on their end of the spectrum, would recommend if they have a discord or a live chat or ticketing system to get more information there as well!
     
  4. Definitely an end on their side, not to mention you're using a bypass to get infinite RAM, be happy they haven't cancelled your server yet.
     
  5. He is using a bypass? I couldn't tell from the logs.

    This issue however has very little to do with Multicraft. Clearly there is another server/plugin listening on 188.40.185.194:25563. I don't see how the hosting company has been unsuccessful to fix the issue, other than being plain incompetent. The least you would expect from a hosting is to test whether it works, after changing the port right?

    https://www.yougetsignal.com/tools/open-ports/ seems port 25563 is open, so something is listening already on the port. Just tried a random port 25569, seems it is closed. Ask your host if you can have port 25569, or any other port that is not in already in use.
     
  6. The last line
    Code (Text):
    [INFO] MC server teminated. Exiting...
    is coming from a bypass that's shared on the darker side of spigot community forums. It overwrites the java flags and makes it so it uses as much RAM as you assign it in the config.

    He just hid the first lines from us, which are these:
    Code (Text):
    [WARNING] Initial attempt to file ourselves failed, attempted method #2. This may silently fail, if on Windows, slots will not work.
    [INFO] MC Server loading! Waiting 10 seconds, then injecting agent... (if slots >= 0)
     
    • Informative Informative x 1
  7. i fixed it by myself the solution :
    my server crashed and i had
    Code (Text):
      restart-on-crash: true
    so it created another instance of java out of daemon
    and i just had to change to
    Code (Text):
      restart-on-crash: false
     
  8. Sorry to jump in on this, however this error is caused because the wrong config is loaded in the multicraft panel. The fact that it starts to load a spigot jar when you are trying to run bungeecord should be enough to see.....