Multicraft Daemon Startup

Discussion in 'Systems Administration' started by Shadow_Console, May 28, 2015.

  1. Hello,
    I've been having some issues when attempting to install Multicraft for the first time on my dedicated server. I have the basics set up, however, when I go to startup the Daemon I get this error.
    Code (Text):
    05.28 13:48:18 ERROR Failed to create pid file: [Errno 13] Permission denied: u'/home/desktop/minecraft/multicraft.pid'
    05.28 13:48:18 ERROR Failed to delete the pid file: [Errno 2] No such file or directory: '/home/desktop/minecraft/multicraft.pid'
    I have already chmod Multicraft's directory to 777, but it didn't seem to do anything.
    Code (Text):
    sudo chmod -R 777 minecraft
    I'd love some support here, thanks!
     
  2. do this:
    Code (Text):

    sudo chown -R minecraft /home/(multicraftuser)
     
     
  3. I ran the following command:
    Code (Text):
    sudo chown -R desktop /home/desktop/minecraft
    Unfortunately, it didn't seem to change anything. Did I run the command as it was intended to be used?
     
  4. wich OS are you using?
     
  5. Xubuntu Desktop 14.04
     
  6. I don't think it is any different than Ubuntu 14.04, it just has remote desktop capabilities. Are they any other commandlines I could use?
     
  7. Have you tried Sudo?
     
  8. Yes, I have. The only way to really start a daemon with Multicraft is through sudo.
     
  9. Rerun multicraft setup but under an different uset
     
  10. Change your directory group permissions:

    chgrp -R <user> /home/desktop/minecraft

    chown -R <user> /home/desktop/minecraft

    Check if your directory (and all subfolders etc) has granted permission to <user>:

    ls -l /home/desktop/minecraft

    Restart daemon
     
    • Agree Agree x 1
  11. Thank you, that solved the problem!
     
  12. Glad to hear that. :)