[Multicraft, Debian 8] Daemon freezes when new server is created

Discussion in 'Systems Administration' started by Loapu, May 7, 2019.

  1. Hello, Spigot community,

    as you may see in the title of this post I have a problem with the Multicraft daemon freezing.

    First the situation: I currently have 3 servers running fine within my Multicraft installation. 2 of them Spigot, 1 BungeeCord. I can start, restart and stop them independently from one another and everything works just fine.

    Then I want to create a new server. So I click on Servers, Create Server, configure it and finally when everything is configured to my likings I click on create and... nothing happens. The page keeps on loading and loading until I finally get a 500 error saying me there was a problem with loading the site.

    The multicraft.log file is no help either. Every time I try to run the daemon (which I had to kill in order to start it again - as I mentioned, the process freezes) it freezes after reaching those lines:

    Code (Text):
    2019-05-07 09:22:46,750 INFO     server 1: [Server] INFO *** Please download a new build as per instructions from https://www.spigotmc.org/ ***
    2019-05-07 09:22:46,750 INFO     server 1: [Server] INFO *** Server will start in 20 seconds ***
    2019-05-07 09:22:47,071 INFO     server 11: Loading server properties
    2019-05-07 09:22:47,072 DEBUG    server 11: Loading server config from spigot.jar.conf
     
    After that.. well... nothing. I have to kill the daemon and the process of server1 (as it is started but not closed) and try again. The exact configuration I try to create the new server with seems to not matter at all. Regardless if I use multiuser or not, try different values for RAM, jars, IPs. Nothing keeps the daemon from freezing.

    Oh and after I got the 500 error I can visit every subpage of my Multicraft panel but direct server pages (e.g. for server1 or server11, etc.).

    If you have the needed knowledge and want some details I will be sure to answer as quickly as possible as I want this to be fixed ASAP.