Multicraft "Failed to adapt server configuration" issue

Discussion in 'Systems Administration' started by geekmakes, Jun 8, 2020.

Thread Status:
Not open for further replies.
  1. 2020-06-07 19:16:24,311 INFO Completed version check, remote version: 2.3.5
    2020-06-07 19:20:22,981 INFO server 1: Received start command
    2020-06-07 19:20:22,981 INFO server 1: Loading server properties
    2020-06-07 19:20:22,981 INFO server 1: Starting server!
    2020-06-07 19:20:22,982 DEBUG server 1: Loading server config from paperclip115.conf
    2020-06-07 19:20:22,983 INFO server 1: Loaded config for "[Paper] 1.13-latest"
    2020-06-07 19:20:22,983 DEBUG server 1: Stream encoding for subprocess: utf-8 in, utf-8 out, latin-1 file
    2020-06-07 19:20:22,988 WARNING server 1: Failed to adapt server configuration
    2020-06-07 19:20:22,988 DEBUG server 1: Failed to adapt server configuration: [Errno 172] Server path '/home/minecraft/multicraft/servers/server1' is writable by others
    2020-06-07 19:20:22,988 INFO server 1: Server stopped
    2020-06-07 19:20:22,988 DEBUG server 1: Loading server config from paperclip115.conf
    2020-06-07 19:24:00,901 INFO Verified license

    Does anyone have any idea how to fix this? I'm assuming the CHMod permissions got messed up but I'm not sure how to undo/repair them.
     
  2. I believe: chown -R mc1:mc1 /home/minecraft/multicraft/servers/server1

    Should do the job.
     
    • Like Like x 1
  3. Yep, that helped get me to the next error but luckily someone had the same one on here and 755 perms got the server to start. Thanks for the help, EnderZ

    For those with the same issue:
    Code (Text):
    chmod 755 -R /home/minecraft/multicraft/servers
     
Thread Status:
Not open for further replies.