Multicraft Giving access to read/write file.

Discussion in 'Systems Administration' started by Valinate, Sep 2, 2018.

  1. Hello, I had a question. I was looking around on spigot to figure out why my Multicraft Panel would not allow users to upload files and start their servers. I found that I needed to use chown on the server folder directory. I found this answer here by @MikeA https://www.spigotmc.org/threads/failing-to-initialize-server-setting-chmod-and-chown.135232/

    Thank you...

    Note: I am running on Ubuntu 14.04

    I now would like to know how can i chown the entire server directory so I do not have to do this for each and every server. This would be helpful! Thank you!

    I also get errors like this when i add custom maps. Not sure why it doesnt like users uploading files.
    https://pastebin.com/1qrt485x

    I also would like to note I tried
    chown -R root:root /home/minecraft/servers
     
  2. You'll need to set your upload permissions, so when you upload a file it can get chmod automatically.
     
  3. @james090500
    Are you sure you should chmod because I did this at first and it ended up making the entire server not work in the past. Also MikeA did say never to chmod in the post I linked.

     
  4. Sorry, I meant chown, basically when a user uploads the files need to be automatically chowned to the correct user.
     
  5. okay, you you mind linking me to how to do this automatically or telling me how I can automatically do this that would be awesome.
     
  6. I am not 100% sure, but if maps are uploaded over FTP it would be in there, or in mutlicraft settings. sorry