Multicraft Help..

Discussion in 'Server & Community Management' started by Caleb, Jul 11, 2013.

  1. I don’t know really know Linux so I am using Multicraft. It is giving me a major issue. I have used Multicraft before, but that was on a minecraft shared server. Now this is on a dedicated server, so I don’t have much support and Multicraft support hasn’t responded. Whenever I try to turn on my server I get this message. http://pastebin.com/ZBCaR4VH The odd part is that I do have a jar folder and my spigot.jar in that folder, yet it still doesn’t work. Here’s what I entered into the server jar box. http://d.pr/i/Tf8J and you can tell that I have spigot in the jar folder.. http://d.pr/i/vIJ2 I’m not quite sure what to do at this point.. As of now I haven't been able to get any server up..
     
    #1 Caleb, Jul 11, 2013
    Last edited: Jul 11, 2013
  2. I'm not an expert on this but have you made sure the spigot.jar file has the proper read/write/access rights?
     
  3. Maybe try setting permissions?
    chmod 777 /home/example/multicraft/servers/server1/jar/spigot.jar

    Replace that with the directory of your multicraft install.
     

  4. I tried this, and I got the same message..
     
  5. Fixed :)
    I helped him
     
    • Winner Winner x 1
  6. Thanks!
     
  7. can you write a tut about it? or can you help me 2? i got the same problem as Caleb
     
  8. Just use chown mc<SERVER_ID>:mc<SERVER_ID> /path/to/server/folder

    Server ID is in the URL :)
     
  9. Experiencing a similar issue, CentOS 6.7 x64. I contacted multicraft support so hopefully they can shine some light on why Spigot cannot access plugins or their config files, for example

    03.12 01:06:36 [Server] INFO GriefPrevention: Unable to write to the configuration file at "plugins/GriefPreventionData/config.yml"

    or why when I try and use multicraft net2ftp to upload server files it fails, and when logging in using the FTP credentials multicraft gives me for that server and user I cannot transfer files. The only way that works is if I log in as root over SFTP, and manually navigate to /home/minecraft/multicraft/servers/server1 and do it that way but then Spigot can't read the files as per the same permission error, UGH
     
  10. tried all the chmod, and chown commands I could think of, even re-reran the multicraft setup.sh file to reset the permissions, nothing. Maybe I should just rerun it again and tell it to run multicraft as root instead of the default "minecraft" user because I'm stuck at a dead end here. Hopefully Multicraft support will be able to help me, if not maybe it's something with the way OVH installs CentOS, idk anymore and

    I'm not willing to wipe and reformat to install Debian or Ubuntu, I'd rather run tmux and use Spigot that way then reinstall my entire system just to accommodate for some software issue. Invested too much time and money to back out of this now
     
    #10 ethancedrik, Dec 3, 2015
    Last edited: Dec 3, 2015