Multicraft not working anymore.

Discussion in 'Server & Community Management' started by ReefUS, Jul 22, 2018.

  1. So earlier I wanted to have a website on my vps (running ubuntu 14.04) this vps also host multicraft with all my server on it. But once I was finished watching this video () neither did the website work but multicraft stopped working as well. So now I am left with this screen. --> upload_2018-7-22_14-7-50.png
    Also to keep in mind multicraft WAS working until I tried what this guy did in the video. All the servers are still running but multicraft is just not showing up.

    I have tried restarting the vps and apache2 webservice multiple times but nothing has changed. I have also reinstalled multicraft but again same thing. Please help!
     
    #1 ReefUS, Jul 22, 2018
    Last edited: Jul 22, 2018
  2. If you don't know what the commands mean in the video, which some of them are quite powerful .. i can imagine you no longer have access to your multicraft.

    Time to restore from backup
     
  3. I got no backups of multicraft so I can't do that.
     
  4. Well, basicly i can do that for you if you pay me. but if you want to get that running on your own. glhf
     
  5. Then check where the files are on the server if you knew where they were.
    Or where they perhaps were moved to.

    Lesson learned, make a backup prior to doing any changes to your setup.
     
  6. Wait @mrfloris, if he provided delete his setup he has to reconfigure everything and yep.
     
  7. I am not going through that whole video i have 0% interest in to find out if he renamed his www/public_html directory or did rm -rf /* etc.
     
  8. Well this sucks... Multicraft says everything is there where its suppost to be but is not working.. even reinstalling multicraft doesn't work.
     
  9. @ReefUS well, reset your server and do it right or msg me if you want someone that doing the setup correctly.
     
  10. Is it posible to just move multicraft files so I don't have to reconfigure
     
  11. That's great news, glad to hear it's there.

    a- make sure your webserver points to the right directory
    b- make sure the right users have the correct rights
    c- make sure you're going to the right path on the website.

    And double check what you have..

    if you uploaded as user bob the multicraft files through sftp to /files/ directory
    but you're running the webserver as another user and you put the files in /var/www/mysite/files/public_html instead of /var/www/mysite/public_html/,

    and stuff like that

    then you can perhaps trace back where it went wrong.
     
  12. did you checked .htaccess ?
     
  13. Wouldn't explain the 404 not found.
     
  14. it wont but its basicly you need to root the folder wheres your files are in, so if you crashed the config of your webserver: gg
     
  15. Since this is all going downhill I'm taking the opertunity to reinstall the os so I wanted to know what would be your suggestions for multicraft to run on.
     
  16. my sugestion is no multicraft. use https://pterodactyl.io/ and then everything is ok and you dont have bugs. basicly i recommed to use docker images for every single server instance.