Multicraft with bungeecord

Discussion in 'BungeeCord Discussion' started by DistortedDorian, Aug 9, 2013.

  1. Hello! I'm trying to make Bungeecord work with my Multicraft control panel which i run on my dedicated server.
    I tried use this script for bungeecord.jar.conf:
    [config]
    name = BungeeCord
    source = http://ci.md-5.net/job/BungeeCord/621/artifact/proxy/target/BungeeCord.jar
    configSource = http://adf.ly/3680772/bungeecord

    [encoding]
    encode = system
    decode = system

    [start]
    command = "{JAVA}" -Xmx{MAX_MEMORY}M -Xms{START_MEMORY}M -Djline.terminal=jline.UnsupportedTerminal -jar "{JAR}" nogui

    [settings]
    restartOnTimeout = True
    followLog = False

    I tried contact Multicraft for help but i doesn't get a answer.
    Anyone know what i can do to make the script work?
     
  2. jeff142

    Benefactor

    All right, fist off we cant use the auto update in bungeecord.jar.conf as md_5 dose not give a "latest version" link like bukkit or vanilla dose.

    So what you need to do, is set your server to look for the jar in the server directory not the jars folder, then sellect any jar, upload bungee to the server, and in multicraft edit the jar name to the bungee name.

    Granted multicraft dose work with bungee, its not compatable with the online check, player count, or stop/restart.
     
    • Disagree Disagree x 2
  3. Wrong. Very wrong. http://ci.md-5.net/job/BungeeCord/lastSuccessfulBuild/artifact/proxy/target/BungeeCord.jar
    This will always be the latest version.
     
    • Informative Informative x 1
  4. jeff142

    Benefactor

  5. Already made Google searches and i send a mail to Multicraft support but they haven't answered since i sent the mail (2 days ago)
    Already tried. didn't go well


    You can always write: "bump" on your topic instead of posting link to it on other topics.
    Ok thanks.

    But i still didn't get a answer on what is wrong with the script i made.
    Anyone else know?
     
  6. md_5

    Administrator Developer

    The fact that your configSource is an adfly link which then 404's is an issue.
     
    • Agree Agree x 1
  7. Hello! A hour ago I edited the script and therefore the AdFly link isn't working and the AdFly link is Non-advertisement (its used as shortcut for the original link). I'm using AdFly because i'm afraid that the original DropBox link is too long.
    this is my new script (its still not working):
    - I tried remove "Djline.terminal=jline.UnsupportedTerminal" from the script
    - I changed "source" to latest successful build from jenkins (thanks to roblabla)
    - I removed [settings] from the script.

    Anyone know else know maybe how to fix BungeeCord with Multicraft?
     
  8. md_5

    Administrator Developer

    1) Multicraft won't follow the adfly
    2) It can't access the target of the adfly:
    https://dl-web.dropbox.com/get/Publ...Tmcx3v2Zb-lHmf2VeXsSPh1qc5egcGXp8s9mnEuQ&dl=1
    Error (403)

    It seems you don't belong here! You should probably sign in. Check out our Help Center and forums for help, or head back to home.
     
    • Agree Agree x 1
    • Disagree Disagree x 1
  9. no that is not that one i make a new one i have another problem
     
  10. Hello. the link isn't working because i'm editing the file and the file get a new url.
    this is my latest with a working url:
    However it's still not working with Multicraft. I think i need use another link for "source ="
    Anyone maybe know something?
     
  11. Outlaw11A

    Supporter

    ugh kids everywhere
     
    • Agree Agree x 5
    • Disagree Disagree x 1
  12. Your comment doesn't belong to this topic.
     
  13. Outlaw11A

    Supporter

    Thanks for clearing this up. Please use your brain before posting.
     
    • Agree Agree x 4
    • Disagree Disagree x 2
    • Funny Funny x 2
    • Like Like x 1
  14. Made a new working script. Any Moderator can feel free to close this topic now.
     
  15. What conf file finally worked? Please share. :)
     
  16. So, what script ended up working?