Multiverse (Core) Portals

Discussion in 'Spigot Plugin Help' started by kaisti4444, Apr 28, 2019.

  1. Has anyone a solution for the errors that we have with Multiverse Portals in 1.14??
    Or must we wait for a new build from the developers?
     
  2. Could you send the errors please ? I'll see if it's possible to use the plugin now, but I think you'll have to wait to the new build :/
     
  3. Is the error when creating portals or when using them?
     
  4. Wenn the server start

    [20:38:36] [Server thread/INFO]: [MVPLogging] 0 - Portals(s) loaded
    [20:38:36] [Server thread/ERROR]: Error occurred while enabling Multiverse-Portals v3.0.0-SNAPSHOT-b790 (Is it up to date?)
    java.lang.NoClassDefFoundError: org/bukkit/TravelAgent
    at com.onarandombox.MultiversePortals.MultiversePortals.registerEvents(MultiversePortals.java:152) ~[?:?]
    at com.onarandombox.MultiversePortals.MultiversePortals.onEnable(MultiversePortals.java:144) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:352) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:416) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.enablePlugin(CraftServer.java:458) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.enablePlugins(CraftServer.java:372) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.reload(CraftServer.java:805) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at org.bukkit.Bukkit.reload(Bukkit.java:576) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:27) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:149) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchCommand(CraftServer.java:707) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchServerCommand(CraftServer.java:692) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at net.minecraft.server.v1_14_R1.DedicatedServer.handleCommandQueue(DedicatedServer.java:433) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at net.minecraft.server.v1_14_R1.DedicatedServer.b(DedicatedServer.java:397) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:953) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:798) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_211]
    Caused by: java.lang.ClassNotFoundException: org.bukkit.TravelAgent
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:81) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_211]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_211]
    ... 18 more
    [20:38:36] [Server thread/INFO]: [Essentials] Enabling Essentials v2.16.1.153
    [20:38:36] [Server thread/ERROR]: [Essentials] You are running an unsupported server version!
    [20:38:36] [Server thread/INFO]: [Essentials] Using 1.8.3+ BlockStateMeta provider as mob spawner provider.
    [20:38:36] [Server thread/INFO]: [Essentials] Using 1.13+ flat spawn egg provider as spawn egg provider.
    [20:38:36] [Server thread/INFO]: [Essentials] Using 1.9+ BasePotionData provider as potion meta provider.
    [20:38:36] [Server thread/INFO]: Loaded 17746 items from items.json.
    [20:38:36] [Server thread/INFO]: Using locale de_CH
    [20:38:36] [Server thread/INFO]: [Essentials] ServerListPingEvent: Spigot iterator API
    [20:38:36] [Server thread/INFO]: [Essentials] Starting Metrics. Opt-out using the global bStats config.
    [20:38:36] [Server thread/INFO]: [Vault][Economy] Essentials Economy hooked.
    [20:38:36] [Server thread/INFO]: [Essentials] Using Vault based permissions (LuckPerms)
    [20:38:36] [Server thread/INFO]: [EssentialsChat] Enabling EssentialsChat v2.16.1.153
    [20:38:36] [Server thread/INFO]: [Multiverse-NetherPortals] Enabling Multiverse-NetherPortals v3.0.0-SNAPSHOT-b749
    [20:38:36] [Server thread/INFO]: [Multiverse-NetherPortals] - Version 3.0.0-SNAPSHOT-b749 Enabled - By Rigby and fernferret
    [20:38:36] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    [20:38:36] [Server thread/INFO]: CONSOLE: Reload complete.
     
    • Like Like x 1
  5. Is there an alternative for Multiverse Portals / signs with spigot 1.14?
     
  6. I've had this happen before and instead moved to something called AdvancedPortals which is working for 1.14, MultiVerse isn't very compatible with 1.14 rn except for inventory and core, so just avoid using it I guess.
     
  7. The Portals are nice but with this Plugin i can't load Multi Worlds. I need a complete solution :eek:
     
  8. Strahan

    Benefactor

    What? AdvancedPortals works fine with multiple worlds. Obviously it is not meant to be standalone though; you still need Multiverse Core which works fine with 1.14.
     
  9. Not realy when i make a netherportal "normal" not with AdvancedPortals i land in the nether from the main world, and i have many errors with MultiverseCore
     
  10. Strahan

    Benefactor

    Well yea, that's the way it works. AdvancedPortals doesn't break the vanilla nether portal mechanics, and vanilla mechanics only send you to the nether for the level specified in server.properties. That's just the way it works.
     
    #12 Strahan, May 6, 2019
    Last edited: May 6, 2019
  11. Has anyone already found a solution to this problem or an alternative that works like Mutiverse?
    I do not want to relink all portals in the Nether

    thanks for your suggestions
     
  12. does anyone know a plugin, where you can use the nether with several worlds?
    One Nether per world like multiverse NetherPortals
     

Share This Page