Multiverse first join spawn

Discussion in 'Spigot Plugin Help' started by elvi81, Jun 12, 2016.

  1. I can't for the love of me get first join spawn to be directed to the multiverse spawn, it ALWAYS goes to the old server World.

    Config.yml, Worlds.yml

    Here's even the Essentials config just for the heck of it Config.yml

    As you probably can see, most is as it should be but yet it goes to the wrong spawn.
    /mv setspawn done in both Worlds.
    /spawn redirected to /mv spawn via commands.yml.
    /spawn in Essentials disabled.

    Mc version is 1.9.4.
    Plugins include:
    AutoSaveWorld
    BetterShops
    BossBarAPI
    Citizens, Blacksmith, Denizen,Sentry
    Essentials, Chat, GroupManager, Spawn
    GriefPrevention
    InfernalMobs
    MarioKart
    MassiveCore, CreativeGates
    mcMMO
    MobArena
    Multiverse-Core, Portals
    ProtocolLib
    PurpleIRC
    Quests
    uCars
    Vault
    WizardlyMagic
    WorldEdit, Guard
     
  2. mathhulk

    mathhulk Retired Moderator
    Retired

    /mv config firstspawnworld [world]
     
  3. Didn't work, same resault as before, the test person went to the old spawn.

    I did /mv config firstspawnworld spawn
     
  4. mathhulk

    mathhulk Retired Moderator
    Retired

    Why not just remove EssentialsSpawn altogether?
    Also, the "test" person has to have never joined before for it to work.
     
  5. I tried removing espawn and didn't work, the testing was done by reming the test persons dat file, every time i did that they ended up in the old spawn.
     
  6. mathhulk

    mathhulk Retired Moderator
    Retired

    Multiverse may not recognize the deletion of the dat file. I did the same with one of my members on my server and they were not reset. I suggest testing an actual new player.
     
  7. Uhm... if i don't delete the file the player spawns at the last location they were at, usualy on the new spawn, if i do delete it, they show up at the old spawn and multiverse complains that they don't have access to it.

    I don't know if this has any significans but the dat files are Always in the old worlds playerdata folder.

    Edit: well this is strange, if i remove my own dat file and launch the server it works like it should, deoping me doesn't change anything either, it just works, puzzling.
     
    #7 elvi81, Jun 13, 2016
    Last edited: Jun 13, 2016
  8. I think i solved it by adding
    /mangaddp default multiverse.access.worldname
    This adds multiverse.access.worldname to the default group via groupmanger.
     
  9. mathhulk

    mathhulk Retired Moderator
    Retired

    Hmm. As I said, try with a brand new player.
     
  10. You should probably read the post under that one.
     
  11. for this, use the Main world in whatever server host your using