Solved Multiverse inventories not shared within grouped worlds

Discussion in 'Spigot Plugin Help' started by SwitchKat, Nov 29, 2019.

  1. Hi all.

    I've been pulling my hair out for weeks trying to get this working so I've come to ask for help. I've been reading every forum post I can find along with all the detailed wiki entries, but nothing has worked.

    First, my setup. I'm running a small server at home for family only and I installed Multiverse (Core (4.1.0-b775), Inventories (3.0.0-b459), NetherPortals (4.1.0-b763), SignPortals (4.1.0-b748)) and LuckyPerms (4.4.1). We had our initial world running since about 1.12 and decided that we'd like to recreate the same world in 1.14 to get the spawns that were missing in everything we had already explored. We also wanted a couple different Creative worlds. I have built the creative worlds and the new survival world, along with its nether world. I have Inventories enabled so that Creative world items cannot be carried over to the Survival worlds.

    I've tried to group the new world and its nether world into the same group so the inventories will pass back and forth, but every time we enter the nether, all our inventories are empty. I've tried the group creation in every possible combination I can think of, but nothing is working. Here's what I'm doing.

    /mv create Home_114 normal
    /mv create Home_114_nether nether

    /mvinv group

    1. Name the group "Home_114_Group"
    2. Add both worlds to the group
    3. Se the sharing to "all".
    Here's what it builds in my groups.yml file.
    groups:

    default:

    worlds:

    - home_nether

    - home_the_end

    - home

    shares:

    - all

    Home_114_Group:

    worlds:

    - Home_114

    - Home_114_nether

    shares:

    - all


    The group gets created successfully with no conflicts. I have tried this scenario several different ways.

    1. Create the group, create the nether world, do NOT enter the nether world, and then add the nether world to the group.
    2. Create the group, create the nether world, ENTER the nether world and go back to the normal world, and then add the nether world to the group.
    3. Create the nether world, do NOT enter the nether world, create the group, and then add the nether world to the group.
    4. Create the nether world, ENTER the nether world, create the group, and then add the nether world to the group.
    None of these are working. I'm obviously missing something, but I cannot find anything that points me to anything specific. Any suggestions?

    Thanks
     
    #1 SwitchKat, Nov 29, 2019
    Last edited: Nov 29, 2019
  2. Is your YML indentation correct?
     
  3. @Nitoblock Yes, I made sure the formatting was correct.

    I actually found the problem, in case anyone else runs into this problem. After digging through the plugin folders for Multiverse, I noticed a JSON file I hadn't seen before. It was named <My_Player_Name>.json under the \plugins\Multiverse-Inventories\worlds\Home_114_nether folder. I opened it and found it was a list of my inventory for my character, but it showed I had nothing in my inventory. I compared this JSON file with the one in my NORMAL world and confirmed what it "should" look like. I removed the JSON file from the \Home_114_nether folder and attempted to go to the nether again. Low and behold, my inventory followed my to the nether. I quickly mined some quartz and headed back, and the quartz came back with me.

    My issues the whole time was this JSON file. I'm not sure why it was there, because I had deleted the world many times in my testing (and confirmed the world folder was deleted), but none of my attempts in grouping the worlds worked. Not sure how it got there, but glad it's working now.