My server isn't cooperating ;-;

Discussion in 'Spigot Help' started by ChickenSaysBak, Jun 2, 2016.

  1. I get this message in console and my server is up but no one can join:

    Read from the bottom up!
    01.06 20:50:14 [Multicraft] Auto-saving world...
    01.06 20:40:13 [Multicraft] Auto-saving world...
    01.06 20:34:11 [Server] INFO Stopping server
    01.06 20:34:11 [Multicraft] Skipped 175 lines due to rate limit (30/s)
    01.06 20:32:29 [Server] ERROR Stack:
    01.06 20:32:29 [Server] ERROR PID: 73 | Suspended: false | Native: false | State: TIMED_WAITING
    01.06 20:32:29 [Server] ERROR Current Thread: File IO Thread
    01.06 20:32:29 [Server] ERROR ------------------------------
    01.06 20:32:29 [Server] ERROR Entire Thread Dump:
    01.06 20:32:29 [Server] ERROR ------------------------------
    01.06 20:32:29 [Server] ERROR java.lang.Thread.run(Thread.java:745)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.MinecraftServer.run(MinecraftServer.java:559)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.MinecraftServer.C(MinecraftServer.java:660)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.DedicatedServer.D(DedicatedServer.java:400)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.MinecraftServer.D(MinecraftServer.java:776)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.WorldServer.doTick(WorldServer.java:248)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.WorldServer.a(WorldServer.java:735)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.BlockCommand.b(BlockCommand.java:77)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.CommandBlockListenerAbstract.a(CommandBlockListenerAbstract.java:103)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.CommandBlockListenerAbstract.executeCommand(CommandBlockListenerAbstract.java:172)
    01.06 20:32:29 [Server] ERROR org.bukkit.craftbukkit.v1_9_R1.command.VanillaCommandWrapper.dispatchVanillaCommand(VanillaCommandWrapper.java:80)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.PlayerSelector.getPlayers(SourceFile:143)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.PlayerSelector.a(SourceFile:482)
    01.06 20:32:29 [Server] ERROR net.minecraft.server.v1_9_R1.World.a(World.java:2494)
    01.06 20:32:29 [Server] ERROR Stack:
    01.06 20:32:29 [Server] ERROR PID: 24 | Suspended: false | Native: false | State: RUNNABLE
    01.06 20:32:29 [Server] ERROR Current Thread: Server thread
    01.06 20:32:29 [Server] ERROR ------------------------------
    01.06 20:32:29 [Server] ERROR Server thread dump (Look for plugins here before reporting to Spigot!):
    01.06 20:32:29 [Server] ERROR ------------------------------
    01.06 20:32:29 [Server] ERROR Spigot version: git-Spigot-f972b36-b103841 (MC: 1.9.2)
    01.06 20:32:29 [Server] ERROR Be sure to include ALL relevant console errors and Minecraft crash reports
    01.06 20:32:29 [Server] ERROR Please report this to http://www.spigotmc.org/
    01.06 20:32:29 [Server] ERROR The server has stopped responding!
     
  2. Sw4p

    Supporter

    I would suggest updating to the latest version of spigot and seeing if the error persists.
     
  3. I'm using an online server hosting program and it has a drop down menu allowing you to select what minecraft version and server you want (such as spigot or tekkit or whatever) And I am on Spigot[2016 Release]: 1.9.x (Automatic Updates) and that appears to be the most updated thing available.
     
  4. Are you able to upload your own .jar file? You can get the latest version of Spigot by using BuildTools. You can download Spigot on other sites if you don't want to use BuildTools, but I don't know if posting those links is allowed, so if you need to, Google it.

    Is that the whole crash log, or did you cut that piece out? It could be a plugin causing it, but I can't tell from what you've posted. Also, using code tags or pastebin.com would be helpful.
     
  5. Sw4p

    Supporter

    I have been seeing this sort of error a lot, i think it may have something to do with outdated java versions. Can you contact your hosting company and ask then the java version you are running.
     
  6. That's a possibility, but I kind of doubt that that's the problem. Since the host added Spigot 1.9 to their list of supported Jars, it makes sense that they would make sure that their servers have the correct Java version for it. Also, if it was an older version of Java, I don't think the server would start up at all.

    I've seen old Java versions causing newer plugins not to load, but in this case I don't think it's causing the whole server to crash. I could be wrong though. It'd still be worth asking the host which version they have, just to rule it out.
     
    • Agree Agree x 1
  7. Sw4p

    Supporter

    I agree asking ain't gonna hurt. I also spent a nit more time staring at this error and you have 1.9.2 installed as it says in the 4th to last line. Truth be told im just a clueless as you. Been up all night figuring it out myself :mad:
    [edit]
    as of just the other day 1.9.4 is now the recommended build.
     
  8. My console is so small it doesn't even catch all of it but all that comes before what I sent was it showing my multiverse worlds being loaded.
     
  9. You can access the whole log from your logs folder.
     
  10. Thank you guys XD It was a plugin causing it, when scrolling thru the log a message caught my eye about one of the plugins not up to date (I didn't really use so..) I removed it and everything is good now lol.
     
  11. RIP nvm.. Now, it lets me occasionally join the server but I can't do any commands and everything is frozen and then when I leave.. it says "Pinging..." forever.
     
  12. Sw4p

    Supporter

    Ok well that tells us that you just made it a bit better by removing a plugin. The problem still persists. I want to say you may have to many plugins and not enough ram for your server? Correct me if im wrong.
     
  13. It would really help if you would post the whole log.
     
    • Agree Agree x 1
  14. Did this ever happen before removing the plugin?

    Check your /tps and do /timings on, /timings merged, /timings paste, and then paste the link here.
     
  15. Yeah basically it's doing exactly what it did before removing the plugin. Possibly removing the plugin didn't do anything at all and it was a coincidence but after removing it and restarting the server, it let me join for 30 seconds and then it went back to how it was. and 1 sec im getting the log.
     
  16. Sw4p

    Supporter

    Well his server is suspended. If those work then yes post them here because it will help a lot along with the full error log. But i did not think timings would work on a suspended server?
     
  17. True... Hmm.

    Try restarting the server and running those commands I posted from the console.
     
    • Agree Agree x 1
  18. Sw4p

    Supporter

    It says it cant load your server icon because it has no space. Also the server suspension happens after the plugin "MyMenu" checks for updates. Maybe turn this feature off?
    [edit]
    by no space i mean no space on the disk ie its out of storage space.
     
  19. Ok, I restarted the server again, it let me join for about 30 seconds, during the first 10, I was able to do commands so I quickly did /tps and got this as a result:

    [​IMG]

    Then I tried the other commands and wasn't able to because then I couldn't type commands and then a few seconds later it said "Timed Out".